Hallo Ralf,
Ja ich werde die HSQL von der 2.0.0 erst mal auf 2.0.5 hochziehen.
Im Download finde ich leider keine 2.0.5 zum laden.
Kannst du mir bitte einen Link senden?
Gruß
Moppedfahn
Ja. Sämtliche Versionen findest Du auf Bitbucket.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo Ralf,
Danke für den Link.
Habe versucht meine HSQL von 2.0.0 mit der 2.0.5 zu starten leider immer der Fehler:
Unable to create class 'com.sebulli.fakturama.views.datatable.products.ProductListTable' from bundle '1046' in: com.sebulli.fakturama.handlers.Open...
Keine Produkte sowie Rechungen sind ersichtlich nur mein Logo ist sichtbar.
Hatte dann mal meine HSQL von 2.0.0 mit der 2.1.0c gestartet .. nun sind Daten ersichtlich aber Kunden und Produkte anlegen ist nicht möglich.
Muss ich noch eine zwischen Version wie z. B 2.0.1 nutzen mit meinen Daten damit ich die HSQL für 2.1.0c kompatibel bekomme?
Gruß
Moppedfahn
Nein, das sollte alles "einfach so" funktionieren. Kannst Du mal testweise Fakturama mit dem Schalter "-clean" starten und mal die Datei %USERPROFILE%\.fakturama2\.metadata\.plugins\org.eclipse.e4.workbench\workbench.xmi löschen.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Moin, ich hab mir gerade mal Deinen ersten Post nochmal durchgelesen. Die Abfolge ist falsch. Probier mal bitte, das anhand dieser Beschreibung durchzuführen. Bis auf die Links zu den Konvertierern sollte es passen. Hier kannst Du den Konverter für die 2.0.0 runterladen. Für die Versionen 2.0.5 und 2.1.0 mußt Du nur den Link entsprechend anpassen. Ich muß das Dok mal noch aktualisieren, dachte, ich hätte das schon getan...
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo Ralf,
habe schon wieder Errors beim Ausführen der migration.grf siehe anghängtes File.
Hier nochmal mein Vorgehen:
Ich habe mein Arbeitsverzeichnis von der Fakturama 2.0.0 mit HSQL Datenbank ( aslo ein Backup) von meinem Live-PC kopiert und auf einen Test- PC kopiert.
Nun habe ich Fakturama 2.1.0c auf dem Test-PC installiert.... oder muss ich hier auch die 2.0.0 nutzen? Wenn ja dann brauche ich noch einen Link zum Download der 2.0.0.
Jetzt bin ich Schritt für Schritt deiner Anleitung:
gefolgt und habe den Konverter HSQL2MYSQL4FAK-2.0.0 benutzt da meine alte Fakturama version die 2.0.0 ist .
Was mache ich falsch?
Gruß
Moppedfahn
Moin, Du mußt auch auf der neuen Maschine erst mal die 2.0.0 nutzen (Link steht oben, verweis auf Bitbucket). Dann kannst Du auf der neuen Maschine (nach der Migration) auch eine neuere Version installieren. Fakturama muß ja einmalig auch die Datenbank in MySQL anlegen. Das muß dann mit der Struktur der zu konvertierenden Daten zusammenpassen.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo Ralf,
Ok habe ich verstanden. Leider ist im Bitbucket die älteste version die 2.0.1.
Kann ich diese verwenden?
Wenn nein -> dann bitte sende mir einen Link für die Version 2.0.0 zum Download.
Vielen Dank im Voraus.
Gruß
Moppedfahn
Moin,
hier der Link (sorry, der ist noch auf dem anderen Webserver gewesen, wußte ich nicht mehr). Falls Du Linux/Mac nutzt bitte nochmal kurz melden.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo Ralf,
habe jetzt die Version 2.0.0.1 installiert. -> die Version von deinem Link.
Ich benutze die Version 2.0.0
und bin der Anleitung gefolgt -> mit Benutzung des Konverters HSQL2MYSQL4FAK-2.0.0
Beim angeben des Arbeitsverzeichnises meckert die Software: -> siehe Bild im Anhang.
Habe dem Bild zu folgen mal mit Nein getestet.
Dann werden die Tabellen in der neuen Mysql datenbank angelegt.
Wenn ich "Ja" in Auswahl teste werden noch nicht mal die benötigten MySQL Tabellen angelegt.
Die PowerShell wurde als Admin gestartet und dann bin\clover migration.grf ausgeführt leider kommt immer noch ein Fehler -> siehe Fehlerlog.
Hast du vielleicht die Version 2.0.0 noch irgendwo verfügbar zum Download?
Gruß
Moppedfahn
Hallo Ralf,
habe doch noch meine Ursprungsversion 2.0.0 gefunden.
Und alles nach der Anleitung durchgeführt aber es kommt wieder der Fehler wie in meinem letzten Beitrag 19.06.2020 23:38h.
Gruß
Moppedfahn
Hm. Irgendwie verstehe ich das aber nicht ganz. Die Fehlerursache liegt hier:
Caused by: java.sql.SQLSyntaxErrorException: user lacks privilege or object not found: FKT_CATEGORY
at org.jetel.connection.jdbc.SQLDataParser.setDataSource(SQLDataParser.java:333)
Da fehlt eine Tabelle in der Datenbank. Wird die Datenbank denn korrekt angelegt? Nach dem ersten Start von Fakturama mit der neuen MySQL-Datenbank sollte die Oberfläche korrekt erscheinen. Ist das der Fall?
Der Datenbank-Verbindungseintrag ist vermutlich auch falsch. Das sollte jdbc:hsqldb:C:/Fakturama2018Feb06/Database/Database heißen, oder?
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo,
Ich hoffe das alle die Feiertag gut über die Runden gebracht haben. Ich wollte ebenfalls auf mysql umziehen- es kommt aber ebenso zu einer nicht fertig abgeschlossenen Migration der Daten. Ich hänge mal den Screenshot der Datenbank und der Fehlermeldung an- vielleicht hat ja einer eine Lösung.
Moin, ich glaube, die Anzahl der Tabellen ist schon ok. Kommt da beim Abbruch irgendeine Fehlermeldung?
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Ich habe heute versucht mit dem Tool HSQL2MYSQL4FAK-2.1.0 die Migration von HSQLDB nach MariaDB versucht aber bereits das erste Migrationsskript läuft auf Fehler, obwohl die vorgängigen Tests alle gut verlaufen.
Hier ist der Auszug aus dem Log.
INFO [WatchDog_0] - -----------------------** Summary of Phases execution **--------------------- INFO [WatchDog_0] - Phase# Finished Status RunTime(sec) MemoryAllocation(KB) INFO [WatchDog_0] - 0 ERROR 0 22000 INFO [WatchDog_0] - 1 N/A 0 0 INFO [WatchDog_0] - 2 N/A 0 0 INFO [WatchDog_0] - 3 N/A 0 0 INFO [WatchDog_0] - 4 N/A 0 0 INFO [WatchDog_0] - 5 N/A 0 0 INFO [WatchDog_0] - 6 N/A 0 0 INFO [WatchDog_0] - 7 N/A 0 0 INFO [WatchDog_0] - 8 N/A 0 0 INFO [WatchDog_0] - 9 N/A 0 0 INFO [WatchDog_0] - ------------------------------** End of Summary **--------------------------- INFO [WatchDog_0] - WatchDog thread finished - total execution time: 0 (sec) DEBUG [WatchDog_0] - unregister MBean with name: org.jetel.graph.runtime:type=CLOVERJMX_1516149394050_0 INFO [main] - Freeing graph resources. ERROR [main] - --------------------------------- Error details ---------------------------------- Component [DBExecute:DB_EXECUTE0] finished with status ERROR. unknown protocol: d ---------------------------------------------------------------------------------- ERROR [main] - Execution of graph failed !
Kann mir jemand sagen, was da passiert? Was könnte "unknown protocol: d" bedeuten?