Hallo zusammen, ich habe Fehler gemacht.
und das mit dem Datenbanksicherung.
Nicht richtig gemacht habe meine Arbeitsverzeichnis mit den Backups der Datenbank vorher Kopiert.
aber nicht die eigentliche Datenbank was mir aber zu spät bewusst wurde.
Die 2.1 Version läuft aber ohne die Daten der Datenbank.
Gibt es irgendwie eine Möglichkeit über die Backups Datei die Datenbank wieder herzustellen oder anders wie wieder an die Daten zukommen.
Danke schon mal
Moin, ich verstehe das Problem nicht ganz. Wenn Du von einer Version 2.x aktualisiert hast und dasselbe Arbeitsverzeichnis verwendest, dürfte die Datenbank konvertiert worden sein. Ansonsten kannst Du einfach das letzte Backup ins Arbeitsverzeichnis entpacken. Dann hast Du die Datenbank von diesem Stand wieder da. Oder habe ich Dich da falsch verstanden?
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
@rheydenr
was ich vielleicht vergessen haben das ganze läuft unter Linux
nach dem update hat es erst mal nicht gestartet nach dem ich dann
die ./faturama2 in home Verzeichnis umbenannte habe. hat er auch gestartet.
habe ein neues Arbeitsverzeichnis angeben und das alte er hat dann auch einiges gemacht und nachgefragt aber nach dem Start sind dann keine alten Daten da.
Moin, von welcher Version kommst Du denn? Von der 1.6.9? Nur dann ist die Migration notwendig. Wenn Du eine Version 2 vorher eingesetzt hast brauchst Du die Migration nicht.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Mahlzeit ich komme von 2.0,4
Habe jetzt das Backup in Arbeitsverzeichnis kopiert
passiert lange nichts dann kommt ne lange Fehler Meldung im neuen Fenster
in der Konsole schreibt er mit.
liquibase.exception.LockException: Could not acquire change log lock.
kenne mich mit der Datenbank nicht aus nur etwas mit mysql.
gibt es Konsolen Programm wo die Lock mit entsperren kann
Ah, ok. Dann mach mal folgendes:
- Verzeichnis ~/.fakturama2 umbennen (oder löschen)
- Backup der Datenbank ins Arbeitsverzeichnis reinspielen (also in das Verzeichnis, mit dem Du dann arbeiten möchtest)
- In Database.script (per Editor öffnen, z. B. nano oder sowas) die Zeile mit "INSERT INTO DATABASECHANGELOGLOCK " löschen (falls sie existiert)
- Fakturama 2 starten, im Intro-Dialog nur das neue(!) Arbeitsverzeichnis auswählen (das, wo Du gerade Deine Datenbank hinkopiert hast)
- Konsole beobachten, ob da irgendwelche Meldungen hochkommen
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo Sorry das ich jetzt erst antworte musste schon zum nächsten Termin...
SO habe das jetzt so gemacht. wie beschrieben hast.
und es hat geklappt super
viele vielen Danke.
Sieht sehr gut aus die neuer Version
Gregor