Die Fehlermeldung sagt, dass der Browser fehlt, richtig.
Midori gibt es als snap. Habe es installiert, aber die Fehlermeldung bleibt leider die gleiche.
Hallo,
die Lösung für mein Problem hat im Juni hier schon mal tscheiby präsentiert:
mdir /tmp/SWT-GDBusServer
Nach Anlegen dieses Verzeichnisses startete Fakturama endlich!
Allerdings nicht ohne Fehlermeldungen:
(Fakturama:3944): Gtk-CRITICAL **: 18:19:32.684: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
** (WebKitWebProcess:4019): ERROR **: 18:19:33.540: Failed to create server: Error binding to address (GUnixSocketAddress): No s
uch file or directory
Ich konnte Fakturama mit den alten Daten verbinden und auch Daten ändern. Bisher sehe ich keine Probleme beim Arbeiten mit dem Programm.
Prima, dann war es ja doch die GDBus-Server Lösung.
Ich habe für das Arch-Package ein Wrapper-Skript hinzugefügt. Wäre klasse, wenn jemand von euch mit dem Problem das unter Arch mal testen kann (da bei mir der Fehler ja nie aufgetreten ist)
2.1.3.c-2 ist die neue Package-Version, die das Problem fixen sollte und die ein Wrapper-Skript hinzufügt unter /usr/share/fakturama2/startup_script
Package: entfernter Link
/usr/share/fakturama2/startup_script
hatte bisher wunderbar funktioniert, seit heute habe ich den Fehler aber wieder. Habe auch versucht das Verzeichnis manuell zu erstellen und chmod -R 777 durchgeführt aber nichts.. Hat jemand einen neuen Fix oder noch Ideen?
Einfach Fakturama in der bash + Fakturama --clean habe ich auch bereits ohne Erfolg ausprobiert.
Hier die terminal Ausgabe:
/usr/share/fakturama2/startup_script WARNING: Using incubator modules: jdk.incubator.foreign, jdk.incubator.vector WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven Aug. 02, 2024 10:44:20 PM javax.money.spi.Bootstrap init INFORMATION: Money Bootstrap: new ServiceProvider set: org.javamoney.osgi.OsgiServiceProvider [Server@53feeac9]: Initiating startup sequence... [Server@53feeac9]: Server socket opened successfully in 11 ms. [Server@53feeac9]: Database [index=0, id=0, db=file:/home/zensiert/Rechnungen2024/Database/Database, alias=fakdbneu] opened successfully in 358 ms. [Server@53feeac9]: Startup sequence completed in 387 ms. [Server@53feeac9]: 2024-08-02 20:44:20.715 HSQLDB server 2.6.0 is online on port 9001 [Server@53feeac9]: To close normally, connect and execute SHUTDOWN SQL [Server@53feeac9]: From command line, use [Ctrl]+[C] to abort abruptly Aug. 02, 2024 10:44:21 PM liquibase.servicelocator INFORMATION: Cannot load service: liquibase.license.LicenseService: Provider liquibase.license.pro.DaticalTrueLicenseService could not be instantiated Aug. 02, 2024 10:44:21 PM liquibase.database INFORMATION: Set default schema name to PUBLIC Aug. 02, 2024 10:44:21 PM liquibase.lockservice INFORMATION: Changelog-Protokoll erfolgreich gesperrt. Aug. 02, 2024 10:44:21 PM liquibase.changelog INFORMATION: Reading from PUBLIC.DATABASECHANGELOG Aug. 02, 2024 10:44:22 PM liquibase.lockservice INFORMATION: Successfully released change log lock Aug. 02, 2024 10:44:22 PM liquibase.database WARNUNG: Failed to restore the auto commit to true [EL Info]: 2024-08-02 22:44:22.567--ServerSession(1614909294)--EclipseLink, version: Eclipse Persistence Services - 2.7.10.v20211216-fe64cd39c3 ** (WebKitWebProcess:34222): ERROR **: 22:44:25.012: Failed to create server: Fehler beim Binden an Adresse (GUnixSocketAddress): Datei oder Verzeichnis nicht gefunden
Moin, Linux kann manchmal echt anstrengend sein... 😀
Das hier
Fehler beim Binden an Adresse (GUnixSocketAddress): Datei oder Verzeichnis nicht gefunden
dürfte die Ursache des Problems sein. Gemäß diesem Artikel dürfte an der glib liegen
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?