Nach Neuinstalltion...
 
Benachrichtigungen
Alles entfernen

Nach Neuinstalltion lädt nicht alle Daten von modified

7 Beiträge
4 Benutzer
0 Reactions
1,183 Aufrufe
(@Larzac)
Active Member
Beigetreten: vor 16 Jahren
Beiträge: 5
Topic starter   [#1383]

Hallo,

Ich nabe einen kleinen modified Shop und nutze Fakturama (Linux) seit ca. 3 -4 Jahre ohne größere Probleme.
Nach einem Festplattenausfall habe ich Fakturama neuinstalliert (erst 1.6.7 und dann versuchweise 1.6.6) und nun habe ich das Problem das nur die Daten bis Ende 2013 heruntergeladen werden.

Vor der Installation gab es kein Problem. Der Connektor scheint korrekt zu funktionieren, keine Fehler-Meldung.
Die Daten sind in Modified vorhanden.
Ich verstehe es absolut nicht, hat jemand eine idee?

Noch ein zweites kleines Problem, aber vielleicht gibt das eine Piste.
Wenn ich das Startbild ändern will, reagiert Fakturama auf keine Veränderung. Es zeigt kein Logo an, es zeigt keine Webpage an - nichts. Die Startseite bleibt grau. Nun erst einmal kein großes Problem, aber evtl. hängt dies mit dem erstgenannten Problem zusammen. Irgendein Fehler bei der Installation???

Beste Grüße
Harald



   
Zitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Hallo Harald,
das ist wirklich seltsam. Es gibt nach meiner Erkenntnis eine Einstellung, die das ein bißchen beeinflußt, die heißt "lastwebshopimport". Die gibt an, wann das letzte Mal etwas vom Shop imortiert wurde. Dieses Datum wird dann auch an den Shop-Connector übertragen und ausgewertet. Bei einer Neuinstallation sollte die aber gar nicht gesetzt sein...

Wie wolltest Du denn das Startbild verändern? Hast Du die XHTML-Seite geändert? Das Problem ist, wenn dort ein Fehler drin ist, wird die Seite nicht angezeigt. Theoeretisch kannst Du die auch im Browser ansehen, da sollte es auch funktionieren.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@Larzac)
Active Member
Beigetreten: vor 16 Jahren
Beiträge: 5
Topic starter  

Hallo Ralf,

Ja, ich finde dies auch alles sehr merkwürdig. Wo kann ich es testen, ob es die "lastwebshopimport" Einstellung ist? Wo finde ich diese?

Zu dem "kleinen Problem". Ja die "Start.html" ist ok. Sie läßt sich im Browser öffnen und hat ja auch so funktioniert bis zur Neuinstallation. Das Arbeitsverzeichnis ist ja noch von der "alten" Installation. Fakturama lädt ja noch nicht einmal die original "Start.html".

Viele Grüße

Harald



   
AntwortZitat
(@moped)
Mitglied Registered
Beigetreten: vor 14 Jahren
Beiträge: 648
 

Hallo Harald,

der Connector holt sich grundsätzlich erst mal nur die Bestellungen, die im Shop als "offen" markiert sind. Sollten da in der Datenbank Bestellungen als "erledigt" oder "versendet" markiert sein, werden die ignoriert. (kann man ändern)
Das Datum bezieht sich auf geänderte Produkte, und sollte sich auf Bestellungen nicht auswirken.
Der Fehler mit der Startseite ist wohl das GTK-Problem unter Linux.
Wie weit es da eine Lösung gibt, weiß ich grad leider nicht.

Gruß moped



   
AntwortZitat
(@Larzac)
Active Member
Beigetreten: vor 16 Jahren
Beiträge: 5
Topic starter  

Hallo Moped,

Danke, es war das Problem mit dem Status!

Das mit Startseite ist wirklich ein Problem.

Vielen Dank für deinen Tipp.

Gruß Harald



   
AntwortZitat
 MAP
(@MAP)
Active Member
Beigetreten: vor 13 Jahren
Beiträge: 12
 

moped schrieb:
-------------------------------------------------------
> Hallo Harald,
>
> der Connector holt sich grundsätzlich erst mal
> nur die Bestellungen, die im Shop als "offen"
> markiert sind. Sollten da in der Datenbank
> Bestellungen als "erledigt" oder "versendet"
> markiert sein, werden die ignoriert. (kann man
> ändern)
> Das Datum bezieht sich auf geänderte Produkte,
> und sollte sich auf Bestellungen nicht auswirken.
> Der Fehler mit der Startseite ist wohl das
> [url= https://www.fakturama.info/community/fehler-verbesserungsvorschlaege/webseiten-und-logo-werden-nicht-angezeigt,65
24#msg-6524]GTK-Problem unter Linux.
> Wie weit es da eine Lösung gibt, weiß ich grad
> leider nicht.
>
> Gruß moped

... wie kann man es ändern, dass nicht nur alle Bestellungen beim Status "offen" sondern auch die mit Status "PayPal bezahlt" geladen werden?

Danke!



   
AntwortZitat
(@moped)
Mitglied Registered
Beigetreten: vor 14 Jahren
Beiträge: 648
 

Welchen Status hat denn "PayPal bezahlt" in der Datenbank?
Wenn du den weißt, kannst du den Connector erweitern.
Finden kannst du den in der Tabelle "orders" Spalte "orders_status".
Oder du suchst in der Tabelle "orders_status" den entsprechenden "orders_status_name" und holst da die "orders_status_id".



   
AntwortZitat
Teilen: