Benachrichtigungen
Alles entfernen

[Gelöst] Fakturama startet aber "leer" ohne Layout, keine Möglichkeit Menüs zu benutzen


 sedi
(@sedi)
Active Member
Beigetreten: vor 2 Jahren
Beiträge: 9
Topic starter  

Tja wie der Betreff schon sagt.. ich nutze Fakturama seit Jahren und das 1x im Monat. Das letzte Mal Anfang Juni.

Jetzt startet Fakturama mit einem leeren Bildschirm und fast alle Menüs sind ausgegraut

hier das .fakturama2/.metadata/.log:

https://del.dog/ynucufoghe

Ich habe auch mal

.fakturama2/.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi

entfernt aber Resultat bleibt identisch.

habe auch irgendwo gelesen das es einen -clean parameter gibt aber den habe ich mich nicht getraut zu nutzen da ich nicht weiß ob dann alles gelöscht wird.. und DAS wäre fatal..

OS: Manjaro Linux x86_64
Host: X580VD 1.0
Kernel: 4.14.183-1-MANJARO

archlinux-java status
Available Java environments:
java-11-openjdk
java-14-openjdk
java-7-openjdk
java-8-jre/jre
java-8-openjdk (default)

Bin über jede Hilfe dankbar..


Zitat
Themen-Schlagwörter
 sedi
(@sedi)
Active Member
Beigetreten: vor 2 Jahren
Beiträge: 9
Topic starter  

Es gab wohl ein Update von Fakturama in der fraglichen Zeit auf 2.1.0.e-2

https://aur.archlinux.org/packages.php?ID=747611

Änderungen:
https://aur.archlinux.org/cgit/aur.git/commit/?h=fakturama&id=ab25ae5f8094913af814413dd6b97cbc85f8fc3e
https://aur.archlinux.org/cgit/aur.git/commit/?h=fakturama&id=5abdbf16c599a72a51853f0811db681f8ac9e9bd

Könnte es sein das hier die Datei/Ordner Berechtigungen Probleme machen?

EDIT:
hm nee.. hab die mal mit meinem Backup verglichen und da waren die identisch zu jetzt und manuell dieses so zu setzen wie im pkginstall bring auch nix..

EDIT2:
Bin auf 2.1.0c zurück per manuellem Downgrade und nun läuft alles wieder.. Was kann das sein? Möchte natürlich die aktuelle Version nutzen.. 🙂

Diese r Beitrag wurde geändert vor 12 Monaten 4 mal von sedi

AntwortZitat
(@rheydenr)
Famed Member Moderator
Beigetreten: vor 8 Jahren
Beiträge: 3860
 

Moin,

lösch mal bitte im Programmverzeichnis alles und installier die neue Version nochmal. Dann am besten Fakturama mit -clean starten. Das Problem liegt daran, daß sich mehrere Bibliotheken ins Gehege kommen. Ich hab den Installer noch nicht richtig angepaßt.

Viele Grüße,
Ralf.


AntwortZitat
 sedi
(@sedi)
Active Member
Beigetreten: vor 2 Jahren
Beiträge: 9
Topic starter  

@rheydenr
und das -clean löscht mir aber nicht meine Daten oder?? 😛

EDIT:
und DANKE für die mega schnelle Antwort!! 🙂

Diese r Beitrag wurde geändert vor 12 Monaten von sedi

AntwortZitat
(@rheydenr)
Famed Member Moderator
Beigetreten: vor 8 Jahren
Beiträge: 3860
 

gerne 🙂 Das clean löscht nur paar Einstellungen. An den Daten wird nichts gemacht.

Viele Grüße,
Ralf.


AntwortZitat
 sedi
(@sedi)
Active Member
Beigetreten: vor 2 Jahren
Beiträge: 9
Topic starter  

@rheydenr
also habe jetzt mal nur das Programmverzeichnis gelöscht und neu drüber installiert. LÄUFT ! 🙂 Dankeschön 🙂


rheydenr gefällt das
AntwortZitat
 sedi
(@sedi)
Active Member
Beigetreten: vor 2 Jahren
Beiträge: 9
Topic starter  

@rheydenr kannst du sagen welche libs hier die Probleme verursachen?
Die Holzhammer-Methode funzt zwar aber so könnte der Arch Linux Installer schon mal angepasst werden wenn wir die genauen Dateien wissen ! 🙂 Danke im Voraus! 🙂


Esentian gefällt das
AntwortZitat
(@rheydenr)
Famed Member Moderator
Beigetreten: vor 8 Jahren
Beiträge: 3860
 

Hm, schwierig. In diesem konkreten Fall war es glaube ich org.apache.commons, das kann aber auch jede beliebige andere Plugin-Datei sein. Ich werde den Installer mal dahingehend verändern, daß er zumindest die Verzeichnisse plugins und features leer räumt. Dort wird bei einer Installation sowieso alles neu geschrieben, der alte Kram stört da nur.

siehe Ticket 885.

Viele Grüße,
Ralf.


AntwortZitat
Teilen: