Libreoffice-Install...
 
Benachrichtigungen
Alles entfernen

[Gelöst] Libreoffice-Installation, Platzhalter in Vorlage werden nicht gefüllt

22 Beiträge
5 Benutzer
0 Reactions
1,105 Aufrufe
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter   [#4359]

Hallo,

noch bin ich am testen und ausprobieren, das Programm scheint mir aber sehr gut für meine Bedürfnisse geeignet. Auf folgendes Problem stoße ich aktuell, wo ich nicht weiter komme:

Ich hatte vergangenen Herbst das erste mal Version 2.1 getestet auf einem tuxedo-Rechner (tuxedo OS auf ubuntu22 Basis) und auch schon Lieferschein- und Rechnungsvorlagen erstellt. Inzwischen habe ich das OS aktualisiert auf jetzt ubuntu24 Basis. Zunächst lief fakturama noch, ließ sich aber irgendwann nicht mehr starten. In einem anderen Beitrag hatte ich gelesen, dass es mit ubuntu24 besser sei, die fakturama2.2beta zu verwenden und siehe da, das Programm läuft wieder.

ABER:

Es hat mir als abhängige Pakete LO24.2.7 mit installiert, was ich nicht mehr los bekomme, ohne gleichzeitig fakturama auch wieder zu deinstallieren. Ich arbeite mit LO24.8, ich kann diese Installation in den Einstellungen auch angeben, möchte aber LO24.2.7 wieder loswerden. Warum wird das als abhängiges Paket mit installiert? Wie bekomme ich es wieder los?

In meiner Rechnungsvorlage bleiben jetzt folgende Felder leer, bzw. sind mit '0' gefüllt:

<ITEM.QUANTITY>
<ITEM.UNIT.NET>
<ITEM.TOTAL.NET>
<ITEM.VAT.PERCENT>
<ITEM.TOTAL.VAT>
<ITEM.TOTAL.GROSS>

Und für die vatlist vermisse ich einen Platzhalter für die nach Prozentsätzen aufgeschlüsselten Brutto-Beträge.

Wie bekomme ich die Werte wieder in die Rechnung?

Viele Grüße

Heiko

Fakturama
Version: 2.2.0-SNAPSHOT
Build-ID: 20250105-1416
Java-Version: 17.0.2

Betriebssystem: TUXEDO OS
KDE-Plasma-Version: 6.2.4
KDE-Frameworks-Version: 6.8.0
Qt-Version: 6.8.1
Kernel-Version: 6.11.0-108013-tuxedo (64-bit)
Grafik-Plattform: X11
Prozessoren: 12 × AMD Ryzen 5 8640U w/ Radeon 760M Graphics
Speicher: 30,6 GiB Arbeitsspeicher
Grafikprozessor: AMD Radeon Graphics



   
Zitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Moin, die Abhängigkeiten sind eine Plage... Lasse ich sie weg, funktioniert irgendwas nicht mehr, schreibe ich sie rein, gibt es nach paar Tagen eine neue Version und alles ist wieder hinfällig... Ich werde wohl irgendwo noch eine Rubrik für Linux-User aufmachen, wo dann alles drinsteht, was an Abhängigkeiten zu installieren ist...

Zu Deiner anderen Frage mit den Platzhaltern: Das scheint ein tiefergehendes Problem zu sein. Stehen in ~/.fakturama2/.metadata/.log (bei Linux / Mac OS) bzw. %USERPROFILE%\.fakturama2\.metadata\.log irgendwelche Hinweise? Man kommt da auch über Hilfe -> Über Fakturama -> Installation Details -> Configuration -> View Error Log ran.

Die Platzhalter stehen auch alle im Handbuch, da müßtest Du mal nachsehen, was gerade paßt.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

hier die log-Datei

die Platzhalter hatte ich lt. Handbuch nochmals abgeglichen, passt.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Hast Du zufällig XRechnung angeschaltet? Irgendwas stimmt mit der Länderkennung nicht...


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

Hallo Ralf,

XRechnung hatte ich mal angeschaltet, zum Ausprobieren. Allerdings möchte ich lieber ZUGFeRD verwenden.

Inzwischen habe ich mein erstes Problem gelöst: Ich hatte LO 24.8 manuell installiert, deshalb hatte Fakturama die Installation nicht erkannt. Jetzt habe ich LO24.8 über ein ppa automatisch installiert, zuvor Fakturama deinstalliert und anschließend neu installiert, ohne dass es Abhängigkeitsprobleme gab.

Vor der Neuinstallation habe ich mein Fakturama Arbeitsverzeichnis umbenannt und ein leeres neues mit gleichem Namen angelegt, um quasi neu anzufangen. Die Einstellungen blieben trotzallem bestehen, wahrscheinlich liegen die dann woanders.

Beim Rechnungsdruck bestehen leider die gleichen Probleme, wie zuvor. Es kam die Fehlermeldung "Dokument konnte nicht erstellt werden. Bitte prüfen Sie den OpenOffice-Pfad und den Ausgabepfad"

Das pdf wurde trotzdem erstellt, die Preis- und Mengenangaben in der Artikeltabelle fehlen weiterhin und es ist keine XML eingebettet.

Es gibt keine neue log-Datei im Log-Verzeichnis!?

Viele Grüße

Heiko



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Das Logfile steht in

~/.fakturama2/.metadata/.log

Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

🙂



   
AntwortZitat
(@a-schmidt)
Active Member
Beigetreten: vor 2 Jahren
Beiträge: 8
 

Veröffentlicht von: @heiko
.

Beim Rechnungsdruck bestehen leider die gleichen Probleme, wie zuvor. Es kam die Fehlermeldung "Dokument konnte nicht erstellt werden. Bitte prüfen Sie den OpenOffice-Pfad und den Ausgabepfad"

..... weiterhin und es ist keine XML eingebettet.

Hallo, genau diese Problem mit der Rechnung hatte ich auch. Die Lösung fand ich in einem anderen Beitrag. Ich musste einmalig eine Datei aus LibreOfficeWriter als PDF-A3 exportieren. Danach klappt es ohne Fehlermeldung. Tatsächlich steht dies auch so im Handbuch, wurde von mir aber auch irgendwie überlesen. 

Viele Grüße Axel

 



   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

Hallo Axel,

ja, das hatte ich auch gelesen und getan, leider besteht das Problem trotzdem weiter... und es werden leider auch weiterhin die Artikel-Felder in der Writer-Vorlage für Lieferschein und Rechnung nicht gefüllt.

Hat jemand eine Idee? Es wäre klasse, wenn ich das gute Stück bei mir zum Laufen bringe! Weiter oben hatte ich eine log-Datei angehängt, ich kann so etwas leider selbst nicht verstehen 😉

Grüße

Heiko



   
AntwortZitat
(@rhe_adm)
Estimable Member Admin
Beigetreten: vor 10 Jahren
Beiträge: 153
 

Kannst Du testweise mal die Standard-Vorlage mal verwenden? Ich kann mir absolut nicht erklären, warum die nicht gefüllt werden sollen.



   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

Hallo Ralf,

anbei zwei Screenshots: die Standard-Vorlage und meine Vorlage im Vergleich, um die Feldnamen zu sehen, entsprechend der Druck einer Rechnung mit der einen und der anderen Vorlage.

Nur das Feld ITEM.TOTAL.GROSS kommt in beiden Vorlagen in der Artikelauflistung vor, in der Standard-Vorlage wird sie gefüllt, in meiner nicht...

Meine Vorlage hatte ich bei meinen ersten Tests vergangenes Jahr mit der fakturama 2.1.3 schon getestet, da wurden die Felder gefüllt, jetzt mit Wechsel auf die beta-Version nicht mehr. Den Wechsel musste ich machen, weil die 2.1.3 auf ubuntu24 nicht läuft.

Viele Grüße

Heiko

 

edit:

PS: die Fehlermeldung beim Druck mit der Standard-Vorlage ist die gleiche und es wird auch keine xml eingebettet.

 

 
 


   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

...hier noch der zweite screenshot, es lässt sich nur eine Datei anfügen.



   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

Hallo Ralf,

durch Zufall bin ich gerade auf eine Lösung gestoßen:

In jeder Zelle der Artikel-Tabelle habe ich das Absatzformat einmal geändert und anschließend mit "Wiederherstellen" in den Ursprungszustand zurück versetzt. Anschließend an egal welcher Stelle ein Zeichen eingefügt und wieder gelöscht, damit ich speichern kann. Jetzt werden die Daten korrekt in die Tabelle übernommen.

Das Problem mit der Fehlermeldung und der fehlenden XML bleibt allerdings leider.

Viele Grüße

Heiko



   
AntwortZitat
(@becherer)
Estimable Member
Beigetreten: vor 2 Jahren
Beiträge: 80
 

Geht die fehlermeldung bezueglich "pdf kann nicht erstellt werden" weg, wenn du "erzeuge zugferd-datei" den haken weg machst?

die 2.2beta macht das bei mir nur wenn ich bei "zusaetzlicher pfad der .pdf dateien einen pfad angebe:

/home/myhome/myfakturamaverzeichnis/Dokumente/TMP/{yyyy}/{doctype}/{docname}_{address}.pdf

wobei bei mir TMP mein muellverzeichnis ist um das problem zu umschiffen. bei anderen laeufts auch

ohne diese angabe, habe aber nicht herausgefunden warum. hier werden dann pdfs ohne eingebettetes xml

gespeichert und im richtigen pdf verzeichnis die mit. - interessanter weise stelle ich gerade fest, dass

es nach einigem rumfummeln mit diesem pfad auch geht, wenn der pfad ins nirwana zeigt, meint

irgendwohin wo er keine schreibrechte hat (hatte tippfehler bei "myhome" und es hat nun trotzdem funktioniert)

 


Fakturama 2.2.0beta auf openSUSE Tumbleweed


   
AntwortZitat
(@heiko)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 27
Topic starter  

Hallo Becherer,

wenn ich den Haken bei Zugferd ganz heraus nehme, kommt keine Fehlermeldung mehr. Der Workaround mit dem zusätzlichen pdf-Pfad hat allerdings leider nicht funktioniert. Die Fehlermeldung erscheint trotz allem, in dem zusätzlichen pdf-Pfad wird die gleiche pdf ohne xml abgelegt.

Ich habe es auch mal mit zugferd 1 versucht: gleiches Problem.

Anbei nochmal die neue log-Datei.

Grüße

Heiko



   
AntwortZitat
Seite 1 / 2
Teilen: