Brauche Hilfe bei d...
 
Benachrichtigungen
Alles entfernen

[Gelöst] Brauche Hilfe bei der Instalation

90 Beiträge
5 Benutzer
5 Reactions
7,364 Aufrufe
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

@mtplus

Bitte lade nochmal das Protokoll hoch...

DANKE!


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

@it-service

Servus Andrée,

.. hmmmm... Ich habe da glaube ich mal einen generellen Denkfehler begangen.
Ich habe Datenverzeichnis und Konfigurationsverzeichnis "kombiniert"; sprich den selben Pfad benutzt.
Das muss ich wohl gleich mal anders machen.

Als Datenbank läuft MariaDB auf einem "Server" (auf einem Raspi), weil ich Mehrplatz-/Multibenutzer realisieren will bzw. muss.

Meines Wissens war auf diesem Rechner niemals eine 32Bit Java-Variante im Einsatz, also sollten da auch keine Reste davon vorhanden sein.

Edit:
Ich habe einen Screenshot der Fehlermeldung gemacht (siehe Anhang)

Dann denke ich, dass ich den Fehler etwas "eingrenzen" konnte:

Konfigverzeichnis gelöscht, Arbeitsverzeichnis woanders angelegt brachte zuerst wieder die Fehlermeldung.
Das Ganze nochmal von vorne ABER Datenbankeinträge weggelassen und Fakturama startet erst mal.

Scheint wohl irgendwie mit der Datenbank zusammen zu hängen.
Hast Du dazu evtl. Tipps dazu?

Beste Grüsse

microangelo


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
(@mtplus)
Trusted Member
Beigetreten: vor 12 Jahren
Beiträge: 65
Topic starter  

Hallo liebe Experten,

 ich habe Fakturama nun in Funktion, jedoch bekomme ich das zweite Arbeitsverzeichnis nicht importiert. Vielleicht hat jemand eine Lösung?

Vielen Dank

Philipp



   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

Kurz off-Topic und ganz dumm gefragt ... warum steht bei meinem letzten Beitrag hier "Moderation ausstehend"?


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

Hallo Philipp.

Versuche mal deine Konfigurationsdatei "weg zu sichern" und anschließend mit dem 2. Unternehmen nochmal neu einzurichten. 

mv ~/.fakturama2/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.sebulli.fakturama.rcp.prefs ~/.fakturama2/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.sebulli.fakturama.rcp.prefs_org

Ohne Konfig kommt der Assistent wieder und da importiert deine Daten aus der alten Version in ein neues Arbeitsverzeichnis.

Anschließend solltest du zwischen den Beiden Firmenverzeichnissen problemlos wechseln können.

Freue mich auf Feedback.

 

Gruß

Andrée


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

Hallo Andrée,

ich kopiere hier mein noch nicht freigegebenes Posting mal (ohne Screenshot) rein:

 

.. hmmmm... Ich habe da glaube ich mal einen generellen Denkfehler begangen.
Ich habe Datenverzeichnis und Konfigurationsverzeichnis "kombiniert"; sprich den selben Pfad benutzt.
Das muss ich wohl gleich mal anders machen.

Als Datenbank läuft MariaDB auf einem "Server" (auf einem Raspi), weil ich Mehrplatz-/Multibenutzer realisieren will bzw. muss.

Meines Wissens war auf diesem Rechner niemals eine 32Bit Java-Variante im Einsatz, also sollten da auch keine Reste davon vorhanden sein.

Edit:
Ich habe einen Screenshot der Fehlermeldung gemacht (siehe Anhang)

Dann denke ich, dass ich den Fehler etwas "eingrenzen" konnte:

Konfigverzeichnis gelöscht, Arbeitsverzeichnis woanders angelegt brachte zuerst wieder die Fehlermeldung.
Das Ganze nochmal von vorne ABER Datenbankeinträge weggelassen und Fakturama startet erst mal.

Scheint wohl irgendwie mit der Datenbank zusammen zu hängen.
Hast Du dazu evtl. Tipps dazu?

Beste Grüsse

Jürgen


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

Ok. Wenn die Installation schon mal läuft kann's ja schon nicht mehr am Java liegen!

An dieser Stelle editiere ich die Konfigurationsdatei gerne von Hand:

# nano ~/.fakturama2/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.sebulli.fakturama.rcp.prefs

Folgende Zeilen geben den Server an:

javax.persistence.jdbc.driver=com.mysql.jdbc.Driver
javax.persistence.jdbc.password=\PASSWORT
javax.persistence.jdbc.url=jdbc\:mysql\://IP-ADRESSE\:3306/DATENBANKNAME
javax.persistence.jdbc.user=DB-USER
jdbc_reconnect=true

Die Syntax (insb. Die Slash & Backslash) sind hierbei essentiell.

Damit sollte es funktionieren...

 

Gruß

Andrée


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

Hallo Andrée,

 

leider funktioniert es (noch) nicht

So sieht aktuell die com.sebulli.fakturama.rcp.prefs aus

GENERAL_WORKSPACE=/fakturama_working/<directory>
eclipse.preferences.version=1
hsqlfiledb=/fakturama_working/<directory>/Database/Database
javax.persistence.jdbc.driver=com.mysql.jdbc.Driver
javax.persistence.jdbc.password=<password>
javax.persistence.jdbc.url=jdbc\:mysql\://192.168.38.249\:3306/fakturama
javax.persistence.jdbc.user=fakturama
jdbc_reconnect=true
standardpayment=1
standardshipping=1
standardvat=1

lieben Gruss

Jürgen


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

hsqlfiledb=/fakturama_working/<directory>/Database/Database

Gibt die lokale Datenbank an. Diese Zeile bitte löschen.

Und ganz wichtig: vor dem Passwort muss ebenfalls ein Backslash "\" stehen.

javax.persistence.jdbc.password=\<password>

 


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

Leider immer noch nicht

Ich bekomme diese Fehlermeldung:
Picturelink: https://share-your-photo.com/033785a8b0

und es wird im home Verzeichnis immer wieder ein Verzeichnis ".eclipse" angelegt.


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

Das Eclipse Verzeichnis ist ganz normal.

Aber die Fehlermeldung ist etwas verstörend - Java-Dejávu  --> Der selbe Fehler wie bei MTplus

Da bin ich jetzt leider erst einmal überfragt...


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
(@mtplus)
Trusted Member
Beigetreten: vor 12 Jahren
Beiträge: 65
Topic starter  

Also ich habe die oben genannten Schitte insbesondere die Javaversion 4-6 mal neugeändert bis das System von Java 8 überzeugt war.

Jetzt funktioniert auch das zweite Arbeitsverzeichnis, jedoch kann ich nicht ohne rm -R ~/.fakturama2/ auszuführen zwischen dne Verzeichnisen wechseln. Bei normalen wechseln kommt die Fehlermeldung s. Log-File im Anhang



   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

@mtplus

Kann leider deinen Anhang nicht finden...


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
(@mtplus)
Trusted Member
Beigetreten: vor 12 Jahren
Beiträge: 65
Topic starter  

Ich glaube das Anhängen der der Datei hat nicht funktioniert. Jo - man kann .log-Dateien nicht anhängen.



   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

Könnte diese Fehlermeldung sich auf das hier beziehen?

http://java-dejavu.sourceforge.net

Ich wüsste zwar nicht dass ich das irgendwann mal verwendet hätte, aber wer weiss?

Würde eine vollständige Deinstallation und Neuinstallation von Java was bringen?
Also eigentlich ein purge anstatt remove?

 


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Seite 2 / 6
Teilen: