Hallo,
bei meiner fakturama2.1.2b-Version habe ich in den Webshop-Einstellungen mal Deinen Webshop angegeben, https://wenzel.co.at/sarshop/wp-admin/admin-ajax.php?do=fakturama.
Damit bekomme ich die gleiche Fehlermeldung wie Du (siehe Anhang). Vielleicht hast Du vergessen den Benutzernamen und das Passwort in den Webshopeinstellungen einzugeben, oder dort ist ein Tippfehler? Und die Daten müssen bei Webshop und nicht bei Webshop-Anmeldung eingegeben werden. (Bei Webshop-Anmeldung kann man angeben, der Webshop sei Passwort-geschützt, diese Angaben spielen bei Woocommerce-Webshops aber keine Rolle. Der Nutzername und das Passwort werden in den Einstellungen bei Webshop angegeben.)
Grüße feli_x
Hallo, nein habe die Benutzerdaten mehrmals überprüft und bei meinem alten Macbook mit Fakturama 1.6.9c gehts ja mit den selben Daten.
(Das ist übrigens nur der Testshop die url die du verwendet hast). Ich verstehe es auch nicht.
LG
Mac mini M1: macOS Ventura / Macbook Air M1: macos Ventura / Mac mini Late 2012: macOS Catalina
Hallo Felix,
benutzt Du irgendwelche "exotische" Zertifikate für deinen Webshop?
Normalerweise sollte der Java-Truststore alle gängigen Zertifikatsanbieter inkludiert haben
LG
Jürgen
microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM
@bluefish75 Hallo nochmals,
hast Du auch überprüft, ob Du die Angaben in den Fakturama-Einstellungen unter "Webshop" und nicht unter "Webshop-Anmeldung" gemacht hast?
Gruß Felix
@feli_x Hallo, ja unter "Webshop-Anmeldung" habe ich alle Felder leer gelassen. Die Anmelde Daten sind nur unter "Webshop".
LG
Mac mini M1: macOS Ventura / Macbook Air M1: macos Ventura / Mac mini Late 2012: macOS Catalina
@bluefish75 Hallo,
dann fällt mir nur noch ein, dass Du die Log-Datei, die beim Import entsteht, ins Forum als Anhang hochlädst. Die java-Experten können die sich dann ansehen und evtl. Tipps geben. Du findest sie unter
/Log/Error..log
Den Pfad zum Arbeitsverzeichnis - falls Du ihn nicht sowieso weist - findest Du, falls Du Fakturama ganz normal durch Klicken auf das App-Icon startest, in der Datei
~/.fakturama2/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.sebulli.fakturama.rcp.prefs
unter GENERAL_WORKSPACE=...
Eine Webshopimport-Log-Datei sieht z.B. so aus, wie die angehängte Datei Error.2021-12-13.log. Diese ist so entstanden, dass ich in den Webshop-Einstellungen für meinen Webshop auf meinem localhost einen falschen Anmeldenamen eingegeben habe.
Gruß feli_x
@microangelo Hallo Jürgen,
ja, ich benutze ein besonderes Zertifikat. Ich habe es mit openssl für apache gemacht und - das Zertifikat ist abgelaufen. Das finde ich aber ok, denn es ist ja sowieso nur auf meinem localhost.
Grüße feli_x
Dann könnte darin das Problem liegen. Java muss normalerweise erfolgreich eine Zertifikatskette aufbauen können, und meines Wissens toleriert Java auch keine abgelaufenen Zertifikate.
microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM
@microangelo Ok, verstehe, danke. Aber zur Zeit habe ich kein Problem mehr. Die Fakturama-Versionen laufen und die Webshopimporte auch.
@feli_x hast du auch eine laufende fakturama2.1.2b-Version mit WooCommerce Anbindung und funktionierenden Webshopmporte?
Grüße
Mac mini M1: macOS Ventura / Macbook Air M1: macos Ventura / Mac mini Late 2012: macOS Catalina
Hallo Günther,
ja, das habe ich. Mein Webshop ist ein Testwebshop auf localhost.
Grüße Felix
Hallo Felix, sehr gut. Ich hab es noch immer nicht mit fakturama 2.1.2b zum laufen gebracht. Du hast ja die openjdk Version installiert, es wird ja nicht daran liegen das ich die Oracle Java Version habe oder?
Den Java Pfad wie bei 1.6.9c unter macOS muß ich ja nicht mehr setzen bei 2.1.2b sonst würde Fakturama ja erst gar nicht starten.
Kannst du mir bitte deine Arbeitsschritte schreiben wie du es unter Mojave mit 2.1.2b zum laufen gebracht hast?
Grüße Günther
Mac mini M1: macOS Ventura / Macbook Air M1: macos Ventura / Mac mini Late 2012: macOS Catalina
Hallo Günther,
an der java-Version (Oracle oder openjdk) wird es wohl nicht liegen.
Schick doch am besten die Log-Datei, die durch den Webshop-Import entsteht, als Anhang hier in einem Post hin. (Wie am 13. Dezember 2021 19:59 von mir hier im Forumsthread beschrieben.) Die Datei Error.*.log und nicht die WebShopImport.log.
Grüße feli_x
Hallo Günther,
ich weiß nicht ob das jetzt gerade an meinem Rechner liegt oder ein genereller Fehler ist:
Wenn ich bei mir im Browser https://wenzel.co.at/sarshop/wp-admin/admin-ajax.php?do=fakturama aufrufe, bekomme ich zuerst mal einen Zertifikatsfehler.
Wenn ich diesen dann 'ignoriere' erscheint die Textmeldung "Please Login!"
Frage an Alle anderen wie sieht das bei Euch aus? Der Login erscheint mir als logisch nur der Zertifikatsfehler macht mich stutzig.
Edit: Nach einem Browserupdate erscheint der Zertifikatsfehler nicht mehr, das war also ein Problem das bei mir verursacht wurde!
Bei einem Aufruf der URL erscheint sofort "Please Login!" Und ich nehme an, das soll auch so sein.
LG
Jürgen
microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM