Wie überhaupt updat...
 
Benachrichtigungen
Alles entfernen

[Gelöst] Wie überhaupt updaten?

22 Beiträge
6 Benutzer
0 Reactions
1,736 Aufrufe
(@redunzl)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 18
Topic starter   [#4263]

Ich würde meine FAKTURAMA-Testumgebung gerne auf die Beta 2.2.0 updaten. Wie erfolgt das Update? Auch mit Blick auf den Arbeitsordner und den .fakturama2-Ordner. Bügle ich die 2.2.0 über die jetzige 2.1.3c-Installation einfach drüber? Wie lautet der Update-Guide? Ich habe im Forum nichts genaues gefunden. Danke im voraus.



   
Zitat
(@lastboyscout)
Reputable Member
Beigetreten: vor 10 Jahren
Beiträge: 249
 

Zu Beginn des Installationsprozess wird abgefragt ob die bestehende Installation aktualisiert werden soll. Vorher natürlich am besten ein Backup des Arbeitsverzeichnis und Benutzerordner so wie ggf. einer externen Datenbank erstellen.


Fakturama 2.1.3 auf Win10 pro x64 an MariaDB auf ner DiskStation


   
AntwortZitat
(@redunzl)
Eminent Member
Beigetreten: vor 2 Jahren
Beiträge: 18
Topic starter  

@lastboyscout Danke für die flotte Antwort. Dann werde ich das mal angehen.

Ich entnehme deiner Signatur, dass deine Datenbank auf einer DS mit MariaDB läuft. Davor scheue ich ehrlich gesagt noch zurück. Zumal es im Forum immer nur Snippets zu diesem Thema gibt. Ich habe eine DS720+ mit installiertem MariaDB. Man benötigt offensichtlich Scripts zur Datenübernahme, von denen im Forum die Rede ist. Wie bist du da vorgegangen? (Gehört jetzt natürlich nicht in das BETA-Forum.)



   
AntwortZitat
(@rhe_adm)
Estimable Member Admin
Beigetreten: vor 10 Jahren
Beiträge: 153
 

Moin, doch, das gehört ins Beta-Forum 😉 Weil nämlich im Zuge der Aktualisierung auch der Wechsel der Datenbank vereinfacht wurde. Deswegen braucht man da kein extra Script mehr.

Das Update geht wie @lastboyscout bereits gesagt hat, indem man den Installer über die alte Version bügelt.



   
AntwortZitat
(@deroj)
Active Member
Beigetreten: vor 9 Jahren
Beiträge: 9
 

Parallel die 2.1.3 zu behalten wird also nicht empfohlen?
Habe ein anderes Installationsverzeichnis genommen, aber dasselbe Arbeitsverzeichnis beim ersten Start angegeben...
Bekomme aber keine Verbindung zur MySQL DB, trotz erfolgreichem Verbindungstest nach Installation.

Vielleicht geht das aber so auch nicht?

 



   
AntwortZitat
(@lastboyscout)
Reputable Member
Beigetreten: vor 10 Jahren
Beiträge: 249
 

@rheydenr die neuste Beta von gestern (09.12.24) bringt bei mir auch eine Fehlermeldung hinsichtlich einer gescheiterten Datenbankverbindung beim Programmstart.

!SESSION 2024-12-10 15:11:39.664 -----------------------------------------------
eclipse.buildId=2.2.0.202412091103
java.version=17.0.13
java.vendor=Eclipse Adoptium
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY com.sebulli.fakturama.common 4 0 2024-12-10 15:13:28.040
!MESSAGE c.s.f.LifecycleManager.checksBeforeStartup:158|couldn't create or update database!

Einstellungen wurden nicht geändert und sind identisch zum Backup. MariaDB ist Online und der Zugriff mit HeidiSQL klappt auch problemlos.


Fakturama 2.1.3 auf Win10 pro x64 an MariaDB auf ner DiskStation


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4912
 

Hast Du mal probiert, über eine komplett neue Installation zu gehen und den Connection-Test am Anfang zu machen? Dazu mußt Du das .fakturama2-Verzeichnis in Deinem Userverzeichnis umbenennen, damit das wieder neu angelegt wird. Ich hab bei mir mit MariaDB getestet, das hat problemlos funktioniert. Welche Version von MySQL setzt Du ein?


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@deroj)
Active Member
Beigetreten: vor 9 Jahren
Beiträge: 9
 

@rheydenr 

Falls du auch mich meinst...

Server-Typ: MariaDB
Server-Verbindung: SSL wird nicht verwendet Dokumentation
Server-Version: 10.5.19-MariaDB - Source distribution
Protokoll-Version: 10

 



   
AntwortZitat
(@lastboyscout)
Reputable Member
Beigetreten: vor 10 Jahren
Beiträge: 249
 

Veröffentlicht von: @rheydenr
Hast Du mal probiert, über eine komplett neue Installation zu gehen und den Connection-Test am Anfang zu machen?

Dies konnte das Verbindungsproblem nicht beheben.

Veröffentlicht von: @rheydenr
Welche Version von MySQL setzt Du ein?

Habe aktuell MariaDB in Version 10.11.6-1369 installiert, was momentan die aktuellste von Synology bereitgestellte Version ist.
Da es sich zwar um eine ältere aber noch unterstützte LTS-Version handelt, sollte dies doch eigentlich auch kein Problem sein!?

 

 


Fakturama 2.1.3 auf Win10 pro x64 an MariaDB auf ner DiskStation


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4912
 

Ja, das sollte passen. Komischerweise hat es bei jemand anderem hier aus dem Forum damit funktioniert. Muß ich mal versuchen, aber bei mir klappt es ja auch...


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@lastboyscout)
Reputable Member
Beigetreten: vor 10 Jahren
Beiträge: 249
 

@rheydenr also wenn ich den .fakturam2 entferne und Fakturama mit dem Connection-Dialog Startet, kann ich die Verbindung zur Datenbank erfolgreich testen. Nach dem anschließenden automatischem Neustart von Fakturama kommt es dann aber wieder genau zu dem selben Fehler.


Fakturama 2.1.3 auf Win10 pro x64 an MariaDB auf ner DiskStation


   
AntwortZitat
(@deroj)
Active Member
Beigetreten: vor 9 Jahren
Beiträge: 9
 

Same here....



   
AntwortZitat
(@jochen)
Eminent Member
Beigetreten: vor 15 Jahren
Beiträge: 19
 

Da meine Versuche mit der letzten offiziellen Version und dem Zugferd nicht wirklich von Erfolg gekrönt waren habe ich eben auch mal auf die Version Installer_Fakturama_linux_x64_2.2.0-BETA.deb aktualisiert.

Meine Konstellation ist die selbige, zwar Linux aber die MariaDB auf einem Synology NAS. Version 10.11.6-1369.

Fakturama startet, fragt nach dem Pfad und der Datenbank, Datenbank Check ist ok, aber dann "No connection to the database":

Failed to create the database connection: liquibase.exception.CommandExecutionException: liquibase.exception.LiquibaseException: liquibase.exception.MigrationFailedException: Migration failed for changeset changelog/db.changelog-2.2.xml::20241014-001::boarschti:
Reason:
changelog/db.changelog-master.xml : liquibase.precondition.core.SqlPrecondition@4cf1ec2 : (conn=65) Table 'XXXDB.fkt_userproperty' doesn't exist

 

Jetzt habe ich aber gesehen das es Reports zu einer Snapshot Version gibt- ist das diese oder gibt es noch irgendwo Snapshots zum Downloaden die ich nicht gefunden habe?

 



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4912
 

Ne, das Paket auf der Betaseite ist schon das neueste. Der Fehler hier ist ein anderer. Leider ist unter Linux Groß- und Kleinschreibung unterschiedlich (das ist bei Windows anders). Deswegen mußt Du in der my.ini (also der Konfig für MariaDB) noch einen Eintrag ergänzen. Wie das geht, steht in dieser Anleitung.

 


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@jochen)
Eminent Member
Beigetreten: vor 15 Jahren
Beiträge: 19
 

Verstehe, das mit dem case sensitive ist mir bekannt, allerdings habe ich es hier nicht als Fehler innerhalb der DB in Erwägung gezogen. Probiere ich später, danke! 😉

 



   
AntwortZitat
Seite 1 / 2
Teilen: