Keine Verbindung zu...
 
Benachrichtigungen
Alles entfernen

Keine Verbindung zum Webserver

12 Beiträge
3 Benutzer
0 Reactions
1,330 Aufrufe
(@butzbussard)
Active Member
Beigetreten: vor 13 Jahren
Beiträge: 11
Topic starter   [#1994]

Guten Tag,

habe alles neu unter Linux installiert. Benutze den Connector für Oscommerce 2.3.1. Liegt im "admin"-Verzeichnis. Das wurde allerdings umbenannt und ist geschützt durch eine htaccess-Datei. Wenn ich importieren will bekomme ich die Meldung: Keine Verbindung zum Webserver. Habe allerdings die URL mehrmals überprüft. User und PW ist eingegeben.
Kann es vielleicht an dem umbenannten Verzeichnis liegen? Oder was ist zu tun?
Danke für Hilfe.

Gruß Manfred



   
Zitat
(@moped)
Mitglied Registered
Beigetreten: vor 14 Jahren
Beiträge: 648
 

Hallo Manfred,
wie ist denn jetzt der Aufruf des Connectors?
Hast du es mal ohne htaccess versucht? Wofür brauchst du die überhaupt, was macht die denn?
Das admin Verzeichnis ist nicht direkt aufzurufen, auch einzelne Dateien nicht.
Wenn das jemand versucht, wird er zum Login geleitet.
Am umbenannten Verzeichnis liegt es eigentlich nicht. Eher an der htaccess, wenn alles andere stimmt.



   
AntwortZitat
(@butzbussard)
Active Member
Beigetreten: vor 13 Jahren
Beiträge: 11
Topic starter  

Moin,
habe die htaccess entfernt. Ist gedacht als zusätzlicher Schutz des Admin-Bereichs.
Jetzt geht die Anmeldung durch, bekomme aber eine andere Fehlermeldung:
Fehler beim Öffnen von:
http://meinedomain.de/pcoshop/catalog/chef2812/fakturama_connector.php
Message:null
Trace:java.io.Reader.(Reader.java:78)
Gibt es noch einen Tipp?



   
AntwortZitat
(@butzbussard)
Active Member
Beigetreten: vor 13 Jahren
Beiträge: 11
Topic starter  

Moin,
ich muß noch was hinterherschieben: Beim letzten Versuch hat es geklappt. Aber ...

Error parsing XML content:
The reference to entity "c-flush.jpg" must end with the ';' delimiter.

5.3.9

dann folgen noch einige Produktdaten ...

Hier bricht der Datenimport ab.

Was kann ich tun?



   
AntwortZitat
(@moped)
Mitglied Registered
Beigetreten: vor 14 Jahren
Beiträge: 648
 

Was steht denn vor "c-flush.jpg" in deiner XML? Ist da ein Sonderzeichen? Ein &, oder sowas?
Die XML findest du in der Datei WebShopImport.log im Ordner Log, falls du es so nicht erkennst.



   
AntwortZitat
(@butzbussard)
Active Member
Beigetreten: vor 13 Jahren
Beiträge: 11
Topic starter  

Ja, da steht c&c-...

Werde ich im Shop ändern und muss dann wohl neu importieren. Sind Sonderzeichen an dieser Stelle und sonstwo immer tabu? Habe z.B. in der XML (Produktbeschreibung) ein § Zeichen gesehen. Wurde anstandslos importiert.
In jedem Fall bin ich von der Software begeistert. Auch die Hilfestellung im Forum ist Top.
Dir besten Dank für die Unterstützung.

Gruß Manfred



   
AntwortZitat
(@moped)
Mitglied Registered
Beigetreten: vor 14 Jahren
Beiträge: 648
 

Das kaufmännische Und, also &, leitet entities ein. Wie z.B.

  oder ü

für ein Leerzeichen und für ein kleines ü stehen. Sie enden mit Semikolon, das wurde vom XML Parser als Fehler ausgeworfen, weil nach dem & kein ; kam.
Es ist also besser auf das & zu verzichten.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

...oder man ersetzt es durch &


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@butzbussard)
Active Member
Beigetreten: vor 13 Jahren
Beiträge: 11
Topic starter  

Hallo,
jetzt muß ich doch noch mal nachhaken: Klappte alles so schön.. die Fehlermeldung, die oben schon mal gepostet hatte

[meinedomain.de]
Message:null
Trace:java.io.Reader.(Reader.java:78)

ist wieder da. Muß dich noch mal bemühen.
Danke.



   
AntwortZitat
(@butzbussard)
Active Member
Beigetreten: vor 13 Jahren
Beiträge: 11
Topic starter  

Hallo,
es gibt noch was zu sagen.

Ich habe alle Produkte importieren können, weil ich die Produkte, die beim Import angemeckert wurden im Shop deaktiviert habe und dann noch einmal auf Import geklickt habe. Sie sind auch mit übernommen worden.
Komisch ist, das die Produkte alle von einem Hersteller sind (ungefähr 20 von insgesamt 265). Was mir noch aufgefallen ist, einige Preise in Fakturama (1.6.1) haben hinten der letzten Zahl nach dem Komma zwei Punkte (89,50..). Ungefähr die Hälfte.

Na ja, und die Kunden hat das Programm komplett ignoriert. Mag daran liegen, dass in osc eine Erweiterung mit Kundengruppen und separaten Preisen installiert ist. Gibt es ggf. dafür eine Lösung?

Danke für weitere Hilfe.
Gruß Manfred



   
AntwortZitat
(@moped)
Mitglied Registered
Beigetreten: vor 14 Jahren
Beiträge: 648
 

Die Frage bei der Erweiterung mit Kundengruppen ist, wie sich dadurch die Einträge der Kunden in der Datenbank geändert haben.
Wenn die Kunden da anders eingetragen werden, kann der Connector sie nicht richtig finden oder zuordnen.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Die zwei Punkte sollen nur andeuten, daß der Preis mehr als zwei Nachkommastellen hat.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
Teilen: