Gelöst: Konvertieru...
 
Benachrichtigungen
Alles entfernen

[Gelöst] Gelöst: Konvertierung von 1.6.9 zu Fakturama2 unter Mac OS 11.2.3

50 Beiträge
3 Benutzer
2 Reactions
3,058 Aufrufe
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

@rheydenr

Wäre ein Weg die Konvertierung auf einem Windows- oder Linux-Rechner zu versuchen?

Löst zwar jetzt nicht das anstehende Problem, aber man könnte zumindest mit den konvertierten Daten weiterarbeiten.


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Kann man versuchen, aber wenn die Daten irgendwie unsauber sind, löst das das Problem nicht. Wäre nur, falls am Format irgendwas nicht stimmt. Mich würde wirklich interessieren, ob während der Konvertierung irgendwelche Fehler auftauchen.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@jaffa_48)
Eminent Member
Beigetreten: vor 5 Jahren
Beiträge: 32
Topic starter  

Wenn Fakturama 2 auf der neuen Maschine mit einer frischen Installation läuft, kann es nur noch ein Konvertierungsproblem sein.

Darauf scheint es hinauszulaufen.

Ich habe – wie beschrieben – versucht, alle Prozesse über das Terminal abzuarbeiten und auch den Neustart von Fakturama2 übers Terminal ausgelöst. Das Resultat endet wie gehabt in einer Fehlermeldung. Aus dem Terminal habe ich alle Zeilen, die für mich nach Fehlerdokumentation aussahen, in die angehängte Textdatei gepackt.

Könnt ihr damit was anfangen?

Gruß --- Jürgen



   
AntwortZitat
(@jaffa_48)
Eminent Member
Beigetreten: vor 5 Jahren
Beiträge: 32
Topic starter  

Lässt sich aus der Fehlerdokumentation denn erkennen, dass da unsaubere Daten in der Datenbank sind, die den Fehler verursachen? Woran könnte ich das beim Durchforsten erkennen? ... und ggf. filtern?



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Nein, in dem Log steht durchgängig nur die Info, daß sämtliche Verbindungswünsche abgelehnt wurden. Sind auf der Maschine irgendwie die lokalen Netzwerkverbindungen blockiert?


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@jaffa_48)
Eminent Member
Beigetreten: vor 5 Jahren
Beiträge: 32
Topic starter  

Ich verstehe die Frage nicht. Verbindung wohin?

Der Rechner ist übers WLAN mit dem Internet verbunden, ansonsten gibt es keinen Server oder andere aktive Verbindungen in einem LAN.

 



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Nein, direkt auf dem Rechner. Manchmal wird sowas vom System selbst blockiert.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@jaffa_48)
Eminent Member
Beigetreten: vor 5 Jahren
Beiträge: 32
Topic starter  

Woran könnte ich das erkennen? Aktiv eingestellt habe ich nichts dergleichen.



   
AntwortZitat
(@jaffa_48)
Eminent Member
Beigetreten: vor 5 Jahren
Beiträge: 32
Topic starter  

Ich habe auf dem alten Rechner – also der, auf dem 1.6.9. problemlos läuft – 2.1.1 installiert und gestartet. Auch dieser Versuch endet in einer Fehlermeldung. (Korrekte Java-Version natürlich auch hier installiert.)

In dem neuen Verzeichnis werden die Ordner Database und Vorlagen angelegt. Wenn ich mir das Databasescript ansehe (Größe 105 Kb anstelle von 8,2 Mb, die es haben müsste), dann bricht die Übernahme der Datenbank offensichtlich ab, bevor die variablen Inhalte übertragen werden.



   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 
Veröffentlicht von: @jaffa_48

dann bricht die Übernahme der Datenbank offensichtlich ab, bevor die variablen Inhalte übertragen werden.

Ja genau, anscheinend kann Fakturama auf den lokalen Datenbankprozess nicht zugreifen.

Veröffentlicht von: @jaffa_48

Der Rechner ist übers WLAN mit dem Internet verbunden, ansonsten gibt es keinen Server oder andere aktive Verbindungen in einem LAN.

Das hat damit nur indirekt zu tun. Auch auf lokale Prozesse wird oft über eine "Netzwerkverbindung" zugegriffen.
Virtuell auf 'localhost' oder '127.0.0.1'.

Sollte das z.B. in der Firewall etc. blockiert sein, kommt natürlich keine Verbindung zustande - womit wir beim oben stehenden Problem wären.


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 
Veröffentlicht von: @jaffa_48

ch habe auf dem alten Rechner – also der, auf dem 1.6.9. problemlos läuft – 2.1.1 installiert und gestartet. Auch dieser Versuch endet in einer Fehlermeldung. (Korrekte Java-Version natürlich auch hier installiert.)

Ist es die selbe Fehlermeldung?

Mich macht stutzig, dass bei Dir irgendwie die Version 2.x.x partout nicht laufen will.


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
(@jaffa_48)
Eminent Member
Beigetreten: vor 5 Jahren
Beiträge: 32
Topic starter  
Veröffentlicht von: @microangelo

 

Mich macht stutzig, dass bei Dir irgendwie die Version 2.x.x partout nicht laufen will.

Guten Morgen, so ganz stimmt das ja nicht: 2.x.x läuft, wenn man es jetzt jungfräulich in Betrieb nehmen würde. Nur die Datenübernahme klappt nicht.

An der Oberfläche sieht die Fehlermeldung beim Starten von 2.x.x identisch aus; ob das im Fehler-Log in allen Details identisch ist, vermag ich nicht zu sagen.

Ich hatte nach den Hinweisen auf die »Netzwerkverbindungen« die Systemeinstellungen gecheckt: Beim neuen Rechner war die Firewall sowieso deaktiviert, beim alten Rechner hatte ich es vorhin ebenfalls gemacht und noch einen Versuch gemacht, der aber auch ins Leere lief.

 

Gruß --- Jürgen



   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 
Veröffentlicht von: @jaffa_48

Guten Morgen, so ganz stimmt das ja nicht: 2.x.x läuft, wenn man es jetzt jungfräulich in Betrieb nehmen würde. Nur die Datenübernahme klappt nicht.

Okay dann habe ich das falsch verstanden.

Da bin ich mit meinem Latein vorerst am Ende. das muss sich Ralf (@rheydenr) genauer ansehen.


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
(@jaffa_48)
Eminent Member
Beigetreten: vor 5 Jahren
Beiträge: 32
Topic starter  

Vielen Dank, Jürgen,  erstmal für dein Engagement.

 

Ralf hat in einer PN genau das angeboten, einmal gemeinsam auf mein Dilemma zu schauen.

Gruß --- Jürgen



   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 
Veröffentlicht von: @jaffa_48

An der Oberfläche sieht die Fehlermeldung beim Starten von 2.x.x identisch aus; ob das im Fehler-Log in allen Details identisch ist, vermag ich nicht zu sagen.

Das wird sich Ralf denke ich genauer ansehen wollen.

Veröffentlicht von: @jaffa_48

Ich hatte nach den Hinweisen auf die »Netzwerkverbindungen« die Systemeinstellungen gecheckt: Beim neuen Rechner war die Firewall sowieso deaktiviert, beim alten Rechner hatte ich es vorhin ebenfalls gemacht und noch einen Versuch gemacht, der aber auch ins Leere lief.

Okay, nach Deiner Schilderung, tippe ich dann eher darauf, dass es ein Problem mit der 'alten' Datenbank gibt und die den Update-Prozess irgendwie blockiert.
Komisch in dem Zusammenhang ist nur dass die Verbindungsversuche abgelehnt werden.


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Seite 3 / 4
Teilen: