Servus Leute!
Mein Fakturama Arbeitsverzeichnis liegt auf meinem Synology-NAS.
Das Arbeiten an meinen Windows-Kisten (1x XP, 1x Win7) funktioniert damit einwandfrei.
Versuche ich nun das Verzeichnis auch auf meinem Linux-PC (Lubuntu 14) zu verwenden erhalte ich immer einen Anbindungsfehler:
Die Ansicht konnte nicht erstellt werden: Es wurde eine unerwartete Ausnahmebedingung ausgelöst.
java.lang.RuntimeException: couldn't connect to database. see error log.
at com.sebulli.fakturama.data.Data.(Data.java:142)
at com.sebulli.fakturama.data.Data.(Data.java:33)
at com.sebulli.fakturama.views.datasettable.ViewDocumentTable.createPartControl(ViewDocumentTable.java:113)
at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:375)
at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:229)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
at org.eclipse.ui.internal.WorkbenchPage$ActivationList.setActive(WorkbenchPage.java:4317)
at org.eclipse.ui.internal.WorkbenchPage$18.runWithException(WorkbenchPage.java:3359)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3563)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3212)
at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)
at org.eclipse.ui.internal.Workbench$33.runWithException(Workbench.java:1600)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3563)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3212)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2609)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at com.sebulli.fakturama.Application.start(Application.java:39)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Kopiere ich das selbe Verzeichnis in den Linux-Rechner kommt das System problemlos in Fahrt und alle Daten sind vorhanden!
Wer hat in dieser Hinsicht schon Erfahrungen gemacht?
Danke, Joe
Was steht denn in dem error log?
Benutzt du auf beiden Systemen die gleiche Java-Version?
Und wie ist das Verzeichnis eingebunden? Über samba, nfs, ftp, DAV, sshfs, ...? Ich vermute mal samba, wenn du von beiden Betriebssystemen auf die identische Freigabe zugreifst. Ohne die genaue Fehlerbeschreibung des error log wird das aber ein stochern im Nebel. Es könnten Pfadangaben sein, die durch das mapping nicht mehr passen. Windows unterscheidet im Gegensatz zu linux bei Dateinamen und Pfaden nicht nach Groß- und Kleinschreibung. Ein gern betretenes Fettnäpfchen.
Gruß
3xhossa
Hallo zusammen,
manchmal passen auch die Rechte nicht...
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo Joe,
ich wollte mal hören, ob Du das Problem lösen konntest?
Bei mir stellt sich das ähnlich dar. Ich würde die Daten von Faktura gerne auf einem Sinologie NAS ablegen und mit meinem Mac darauf zugreifen wollen.
Wäre schön, wenn Du dazu noch was schreiben könntest, auch wenn der Thread schon etwas älter ist.
Viele Grüße
Andreas
Hallo zusammen,
vielleicht hilft es ja anderen mit ähnlichem Problem:
Ich habe das jetzt so gelöst, dass ich die zwei Rechner, mit denen ich abwechselnd arbeite mit dem Cloud Station Client von Synology ausgestattet habe und das lokale Fakturama Verzeichnis mit dem NAS synchronisiere.
So habe ich auf beiden Rechnern immer den gleichen Datenstand.
Man kann aber natürlich nicht gleichzeitig an beiden Rechnern arbeiten!
Beste Grüße
Andreas
Um auf ein NAS mit (L)ubuntu auf ein NAS zuzugreifen empfehle ich unbedingt das nfs Protokoll zu verwenden und nicht über Samba.
Das funktioniert nicht nur einwandfrei, sondern ist auch wesentlich schneller.
------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.8 | Win10@LAN 20.04| MySQL 5.7.26@UbuntuServer 18.04.3 | QRK
------------------------------------------------------------