2.1.0e unter Window...
 
Benachrichtigungen
Alles entfernen

2.1.0e unter Windows nach Update oder Neuinstallation nicht lauffähig.

9 Beiträge
2 Benutzer
0 Reactions
545 Aufrufe
(@willie68)
Active Member
Beigetreten: vor 6 Jahren
Beiträge: 17
Topic starter   [#2802]

Wie schon in früheren Post, nach einem Update oder einer Neuinstallation kommt die 2.1.0e mit einem leeren Fenster hoch.
Alle Menüpunkte sind ausgegraut, bis auf Erstellen. Aber auch da passiert nix. Fehlermelung in der Log
(Nur das wichtigste)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.lang3.BooleanUtils cannot be found by com.sebulli.fakturama.rcp_2.1.1.202005291928
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:514)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:425)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:171)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 40 more

Da fehlt wohl was im Deployment.



   
Zitat
(@willie68)
Active Member
Beigetreten: vor 6 Jahren
Beiträge: 17
Topic starter  

Auch eine 2.1.0 will mit meinen Daten nicht.
Nachdem ich ja jetzt mühsam die nicht updatebaren Felder korrigiert habe, und vergebens die 2.1.0e probiert habe, geht mit der 2.1.0 auch nichts.
Und es kommen auch keine Log Meldungen mehr.
2.0.5 drüber installiert... Datenbank Lock entfernt, läuft wieder.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

hast Du nach der Installation von 2.1.0e die Datei %USERPROFILE%\.fakturama2\.metadata\.plugins\org.eclipse.e4.workbench\workbench.xmi gelöscht?


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@willie68)
Active Member
Beigetreten: vor 6 Jahren
Beiträge: 17
Topic starter  

Ja, auch,
erst Update auf 2.1.0e, fkt. nicht. Dann alles deinstalliert und gelöscht und einen komplette Neuinstallation der 2.1.0e gemacht.
Da kam eben immer der ClassNotFoundException hoch.

Bei der 2.1.0 (Nach Empfehlungen hier im Forum) auch eine Neuinstallation, kam zunächst der Übername Dialog. Und dann hing das ganze bei Checking Database... Im Log war keine Meldung.

Wieder deinstalliert und eine 2.0.5 installiert -> alles lief sofort.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Wenn's beim "checking database" sehr lange hängt ist oftmals auch ein Lock-Eintrag schuld. Da müßtest Du in der Datenbank die Zeile mit "INSERT INTO DATABASECHANGELOGLOCK" löschen.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@willie68)
Active Member
Beigetreten: vor 6 Jahren
Beiträge: 17
Topic starter  

Ich hab's mir einfach gemacht und immer meine Datensicherung neu eingespielt. ? 

Somit hab ich da immer einen sauberen Stand.
Ich bastel ja nie ohne Backup.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Wenn Du Fakturama mit -consoleLog startest siehst Du möglicherweise mehr. Da werden einige Meldungen mit ausgegeben.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@willie68)
Active Member
Beigetreten: vor 6 Jahren
Beiträge: 17
Topic starter  

2.1.0e gleiches Verhalten. Da fehlt einfach nach der Installation die Klasse.

2.1.0c bleibt einfach stehen. Keine weiteren Ausgaben ausser

WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven
[Server@6a2c717f]: Initiating startup sequence...
[Server@6a2c717f]: Server socket opened successfully in 2 ms.
[Server@6a2c717f]: Database [index=0, id=0, db=file:E:\DATEN\Fakturama2.1/Database/Database, alias=fakdbneu] opened successfully in 296 ms.
[Server@6a2c717f]: Startup sequence completed in 300 ms.
[Server@6a2c717f]: 2020-12-08 12:37:50.544 HSQLDB server 2.5.0 is online on port 9002
[Server@6a2c717f]: To close normally, connect and execute SHUTDOWN SQL
[Server@6a2c717f]: From command line, use [Ctrl]+[C] to abort abruptly



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Moin, das sieht aber wirklich stark nach einem Lock aus (die Datenbank wartet, bis die vermeintliche Sperre wieder aufgehoben wird). Ansonsten hilft es auch manchmal, das Verzeichnis plugins (im Programmverzeichnis) komplett zu löschen und Fakturama 2.1.0e dann nochmal drüberzuinstallieren. Außerdem sollte man die Datei %USERPROFILE%\.fakturama2\.metadata\.plugins\org.eclipse.e4.workbench\workbench.xmi löschen.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
Teilen: