Benachrichtigungen
Alles entfernen

[Gelöst] Fehlermeldungen

5 Beiträge
2 Benutzer
0 Reactions
2,407 Aufrufe
(@andreas)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 15
Topic starter   [#24]

Hallo,

nachdem ich nun ein paar Rechnungen erstellt hatte, wurde das füllen der Office-Dokumente immer langsamer. Dann sah ich die Fehlermeldungen:

I:Fakturama Workbench opened
E:Fatal Error: ID -1 not in Dataset : -1 in: com.sebulli.fakturama.data.DataSetArray/getDatasetById(231)

Nach einem Neustart von Fakturama ging dann alles wieder richtig schnell.

Übrigens, kann man die Startseite irgendwie anschalten?

Grüße
Andreas



   
Zitat
 Gerd
(@admin_gerd)
Honorable Member
Beigetreten: vor 16 Jahren
Beiträge: 514
 

Hallo Andreas,
kannst Du mir die /Log/Error.log Datei mal zumailen.
Dort steht die Fehlermeldung auch drin, und anhand den Meldungen davor (die stehen je nach dem auch erst in der nächsten Zeile) kann man ablesen, an welcher Stelle der Konflikt passiert ist.
fakturama(klammeraffe)sebulli.com

[quote="Übrigens, kann man die Startseite irgendwie anschalten?"]

Die Startseite im Browser-Fenster ? Die kann man seit SVR r317 auf jede beliebige URL setzen ( auch lokale Datei ) - oder ganz abschalten. Ist also im nächsten Update drin.

Gerd



   
AntwortZitat
 Gerd
(@admin_gerd)
Honorable Member
Beigetreten: vor 16 Jahren
Beiträge: 514
 

Hallo Andreas,

ich hab die Error.log erhalten. Man erkennt am Eintrag "DocumentEditor.java:594", dass der Fehler deswegen auftaucht, weil zuerst die ID der Standard-Versandart gelesen wird, und diese dann übernommen wird.
Fälschlicherweise steht die jedoch auf "-1".

Dies wurde schon einmal berichtet: Fehler beim Öffnen von: ..

Lösung war, die Standard-Versandart neu zu setzen:

- Menü "Versandarten".
- Eine Versandart anwählen und diese öffnen.
- Dort auf den Knopf "zum Standard machen".

Mich würde vor allem die Ursache interessieren.
Könntest Du deshalb, bevor Du das machst mal folgendes überprüfen:

- Fakturama schließen.
- Im Arbeitsverzeichnis im Ordner "Database" die Datenbank "Database.script" in einem Texteditor öffnen.
- nach der Zeichenkette "standardshipping" suchen.

Dort sollte so etwas stehen wie:

INSERT INTO PROPERTIES VALUES(3,'standardshipping','0')

- Database.script wieder schließen. Auf keinen Fall etwas ändern oder speichern.

Gerd



   
AntwortZitat
(@andreas)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 15
Topic starter  

Hallo Gerd,

bei mir steht:

INSERT INTO PROPERTIES VALUES(3,'standardshipping','-1')

Ich kann Dir auch die Datenbank zusenden.

Gruß
Andreas



   
AntwortZitat
 Gerd
(@admin_gerd)
Honorable Member
Beigetreten: vor 16 Jahren
Beiträge: 514
 

ok. Fehler gefunden und gefixt in SVN r323.

Wenn eine neue Versandart geöffnet wird, dann hat diese noch keine ID (-1). Sie bekommt diese erst, wenn sie gespeichert wird. Wenn man vor dem Speichern auf "Diese Versandart zum Standard machen" klickt, dann wird als Standard Versandart "die mit der ID -1" im System gespeichert.

Das erzeugt diese Fehlermeldung. Mann kann das aber einfach wieder hinbiegen, indem man sie NACH dem Speichern auf Standard setzt. Im nächsten Update wird dies dann abgefangen.

Das mit dem "immer langsameren OpenOffice" ist was anderes.

Gerd



   
AntwortZitat
Teilen: