Hi!
Ich habe vor einigen Tagen das Update von MacOS Catalina auf Ventura installiert. Danach musste ich zunächst Fakturama auf die neuste Version (Version: 2.1.3-SNAPSHOT, Build-ID: 20221216-0937, Java-Version: 17.0.5) updaten. Meine Rechnungen, Debitoren und alle Einstellungen wurden problemlos übernommen.
Allerdings sagt die Fehlerkonsole schon direkt beim Programmstart:
Unable to create class com.sebulli.fakturama.parts.DocumentEditor from bundle 72 in: # (-1)
Wenn ich dann eine neue Rechnung erstellen möchte, kommt ergänzend noch diese Zeile hinzu...:
Unable to create class com.sebulli.fakturama.parts.DocumentEditor from bundle 72 in: com.sebulli.fakturama.handlers.CallEditor#exe cute (224)
... und der Tab, in dem ich normalerweise meine Rechnung anlege, bleibt komplett grau.
Was muss ich tun, damit Fakturama wieder funktioniert?
Vielen Dank und liebe Grüße!
(sorry für die vielen edits im Post. Die Foren-Software mochte wohl das Wort "execute" nicht, das in der einen Fehlermeldung vorkommt, so dass ich Zeile für Zeile meinen Text sozusagen debuggen musste...)
microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM
Tja... Da kann ich tatsächlich auch nur raten. Stehen in ~/.fakturama2/.metadata/.log (bei Linux / Mac OS) bzw. %USERPROFILE%\.fakturama2\.metadata\.log
irgendwelche Hinweise? Man kommt da auch über Hilfe -> Über Fakturama -> Installation Details -> Configuration -> View Error Log ran.
Möglicherweise können das auch irgendwelche unvollständigen Steuersätze oder Versandkosten sein.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Danke für den Tipp mit den Log-Dateien. Ich musste erstmal einen neuen Nutzernamen für's Forum erstellen, weil ich wohl wegen der vielen Posting-Versuche mit dem Code oben gebanned wurde... und wie ich den Forum-Admin kontaktieren kann, wie mir geraten wurde, finde ich nirgends. 🙄
Ich werde aus den Log-Dateien nicht viel schlauer als aus der ursprünglichen Fehlermeldung. Aber ich hänge sie mal an diese Nachricht an. Vielleicht weiß nach diesen Infos jemand Rat?
Ich selber kann da im Moment auch nur raten. Das Logfile muss sich Ralf (@rheydenr) ansehen.
Was mir so aktuell noch einfällt:
- Hast Du schon geprüft ob Steuersätze und Versandkosten richtig angelegt sind?
Da kommen nämlich oftmals ähnliche Fehler her. - Hast Du in irgendeiner Form ZUGFeRD (XRECHNUNG) aktiviert?
Falls Ja, hast Du das auch richtig konfiguriert?
Ggfs. ZUGFeRD (falls aktiviert) deaktivieren und sehen ob der Fehler trotzdem noch kommt.
Mehr kommt mir da aktuell nicht in den Sinn.
LG
Jürgen
microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM
Hallo Jürgen,
- Hast Du schon geprüft ob Steuersätze und Versandkosten richtig angelegt sind?
Da kommen nämlich oftmals ähnliche Fehler her.
Das sieht alles in Ordnung aus. Versandkosten habe ich nicht eingegeben, aber die werden in meiner Rechnungsvorlage auch gar nicht genutzt.
- Hast Du in irgendeiner Form ZUGFeRD (XRECHNUNG) aktiviert?
Falls Ja, hast Du das auch richtig konfiguriert?
Ggfs. ZUGFeRD (falls aktiviert) deaktivieren und sehen ob der Fehler trotzdem noch kommt.
ZUGFeRD habe ich nicht aktiviert.
Ich habe mal überprüft, welche Dokumentarten nicht geladen werden, also bei welchen die Registerkarte nur eine graue Fläche lädt.
Normal laden die Registerkarten für:
- Neuer Brief
- Neue Rechnungskorrektur
Nichts geladen wird bei:
- Neues Angebot
- Neuer Auftrag
- Neue Auftragsbestätigung
- Neue Rechnung
- Neuer Lieferschein
- Neue Mahnung
- Neue Proforma-Rechnung
Vielleicht hilft das, den Fehler einzugrenzen?
Ich habe auch ein neues Arbeitsverzeichnis angelegt, um zu überprüfen, ob es mit dem Dropbox-Speicherort zusammenhängen könnte. Da hat aber auch keine Besserung gebracht.
Alle o.g. Fenster, die nicht funktionieren generieren die Fehlermeldung "Unable to create class com.sebulli.fakturama.parts.DocumentEditor from bundle 72 in com.sebulli.fakturama.handlers.CallEditor... usw.
Das sieht alles in Ordnung aus. Versandkosten habe ich nicht eingegeben, aber die werden in meiner Rechnungsvorlage auch gar nicht genutzt.
Dann lege mal bei den Versandkosten einen Satz mit "ohne Versand" und 0,00EUR an.
Selbst wenn Du diese nicht nutzt könnte sonst ein Problem verursacht werden. Deine Schilderung deutet nämlich schon was in diese Richtung an.
Ich habe auch ein neues Arbeitsverzeichnis angelegt, um zu überprüfen, ob es mit dem Dropbox-Speicherort zusammenhängen könnte. Da hat aber auch keine Besserung gebracht.
Ich nehme mal an Du meinst, dass das Arbeitsverzeichnis auf der Dropbox liegt.
Wenn Du Fakturama mit der 'internen' HSQLDB-Datenbank verwendest ist das keine gute Idee. Das kann durch das dauernde Hin- und Her-Synchronisieren gewaltige Inkonsistenzen in der Datenbank verursachen.
microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM
@microangelo Ein Standardversand von 0,00 EUR war bereits eingerichtet. Ich habe jetzt noch mal probeweise eine Kategorie eingefügt. Gleiches bei der Steuernummer. Keine Veränderung. Die Dropbox als Arbeitsverzeichnis hat jahrelang ohne Probleme funktioniert. Ich hatte heute auch mal ein neues Arbeitsverzeichnis in einem lokalen Ordner eingerichtet. Hilft auch nicht. 🙁
microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM