Ich bekomme beim ersten Start folgenden Fehler wenn ich versuche Fakturama mit Mariadb 10.5.* zu betreiben:
19:07:04.810 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - 1 row(s) affected 19:07:04.815 [main] DEBUG l.changelog.visitor.UpdateVisitor - Running Changeset:/changelog/db.changelog-2.0.xml::20180104-001::rheydenr (generated) 19:07:04.816 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - Changeset /changelog/db.changelog-2.0.xml::20180104-001::rheydenr (generated) 19:07:04.816 [main] DEBUG liquibase.changelog.ChangeSet - Reading ChangeSet: /changelog/db.changelog-2.0.xml::20180104-001::rheydenr (generated) 19:07:04.817 [main] DEBUG l.database.core.MariaDBDatabase - Executing Statement: liquibase.statement.core.ModifyDataTypeStatement@1820f274 19:07:04.817 [main] INFO liquibase.executor.jvm.JdbcExecutor - ALTER TABLE `fakturama`.`FKT_CONTACT` MODIFY `NOTE` LONGTEXT 19:07:04.924 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - 0 row(s) affected 19:07:04.924 [main] INFO liquibase.changelog.ChangeSet - FKT_CONTACT.NOTE datatype was changed to LONGTEXT 19:07:04.924 [main] DEBUG l.database.core.MariaDBDatabase - Executing Statement: liquibase.statement.core.ModifyDataTypeStatement@221cdd87 19:07:04.924 [main] INFO liquibase.executor.jvm.JdbcExecutor - ALTER TABLE `fakturama`.`FKT_PAYMENT` MODIFY `DEPOSITTEXT` VARCHAR(4096) 19:07:04.934 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - 0 row(s) affected 19:07:04.934 [main] INFO liquibase.changelog.ChangeSet - FKT_PAYMENT.DEPOSITTEXT datatype was changed to VARCHAR(4096) 19:07:04.934 [main] DEBUG l.database.core.MariaDBDatabase - Executing Statement: liquibase.statement.core.ModifyDataTypeStatement@4d66cb 19:07:04.934 [main] INFO liquibase.executor.jvm.JdbcExecutor - ALTER TABLE `fakturama`.`FKT_PAYMENT` MODIFY `DESCRIPTION` VARCHAR(8192) 19:07:04.948 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - 0 row(s) affected 19:07:04.948 [main] INFO liquibase.changelog.ChangeSet - FKT_PAYMENT.DESCRIPTION datatype was changed to VARCHAR(8192) 19:07:04.948 [main] DEBUG l.database.core.MariaDBDatabase - Executing Statement: liquibase.statement.core.ModifyDataTypeStatement@7c79f2cf 19:07:04.949 [main] INFO liquibase.executor.jvm.JdbcExecutor - ALTER TABLE `fakturama`.`FKT_PAYMENT` MODIFY `PAIDTEXT` VARCHAR(4096) 19:07:04.950 [main] ERROR liquibase.changelog.ChangeSet - Change Set /changelog/db.changelog-2.0.xml::20180104-001::rheydenr (generated) failed. Error: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs [Failed SQL: (1118) ALTER TABLE `fakturama`.`FKT_PAYMENT` MODIFY `PAIDTEXT` VARCHAR(4096)] 19:07:04.951 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - Release Database Lock 19:07:04.952 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - UPDATE fakturama.DATABASECHANGELOGLOCK SET `LOCKED` = 0, LOCKEDBY = NULL, LOCKGRANTED = NULL WHERE ID = 1 19:07:04.960 [main] INFO l.lockservice.StandardLockService - Successfully released change log lock liquibase.exception.MigrationFailedException: Migration failed for change set /changelog/db.changelog-2.0.xml::20180104-001::rheydenr (generated): Reason: liquibase.exception.DatabaseException: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs [Failed SQL: (1118) ALTER TABLE `fakturama`.`FKT_PAYMENT` MODIFY `PAIDTEXT` VARCHAR(4096)] 19:07:04.973 [Equinox Log Thread - Equinox Container: c269ad11-c92f-45f1-b889-9f67e86d8c68] ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available! 19:07:04.981 [Equinox Log Thread - Equinox Container: c269ad11-c92f-45f1-b889-9f67e86d8c68] ERROR com.sebulli.fakturama.common - couldn't create or update database!
Laut https://wiki.archlinux.org/index.php/MariaDB#Increase_character_limit sind bereits alle Maßnahmen die ich bei der Config von MariaDB machen kann per default aktiv.
Leider bin ich jetzt nicht gerade der Datenbankspezialist aber ich habe festgestellt das ich bei 2.1.0 weiter komme wenn ich das "default-character-set" auf latin1 setze (was eigentlich der default bei mariadb ist aber unter ArchLinux ist es utf8mb4) aber dann kommt halt dieser Fehler:
9:21:42.283 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - Release Database Lock 19:21:42.284 [main] DEBUG liquibase.executor.jvm.JdbcExecutor - UPDATE fakturama.DATABASECHANGELOGLOCK SET `LOCKED` = 0, LOCKEDBY = NULL, LOCKGRANTED = NULL WHERE ID = 1 19:21:42.291 [main] INFO l.lockservice.StandardLockService - Successfully released change log lock liquibase.exception.MigrationFailedException: Migration failed for change set /changelog/db.changelog-2.1.xml::20190915-050::rheydenr: Reason: liquibase.exception.DatabaseException: Row size too large (> 8126). Changing some columns to TEXT or BLOB may help. In current row format, BLOB prefix of 0 bytes is stored inline. [Failed SQL: (1118) CREATE TABLE fakturama.TMP_CONTACTS_WITH_ADDRESSES (BILLING_ADDRESS_ID BIGINT NOT NULL, BILLING_ADDRESS_CITY VARCHAR(255) NULL, BILLING_ADDRESS_CITYADDON VARCHAR(255) NULL, BILLING_ADDRESS_COUNTRYCODE VARCHAR(255) NULL, BILLING_ADDRESS_DATEADDED date NULL, BILLING_ADDRESS_DELETED BIT(1) DEFAULT 0 NULL, BILLING_ADDRESS_MANUALADDRESS VARCHAR(4096) NULL, BILLING_ADDRESS_MODIFIED date NULL, BILLING_ADDRESS_MODIFIEDBY VARCHAR(255) NULL, BILLING_ADDRESS_NAME VARCHAR(255) NULL, BILLING_ADDRESS_STREET VARCHAR(255) NULL, BILLING_ADDRESS_VALIDFROM date NULL, BILLING_ADDRESS_VALIDTO date NULL, BILLING_ADDRESS_ZIP VARCHAR(255) NULL, BILLING_CONTACT_ID BIGINT NOT NULL NULL, BILLING_CONTACT_DTYPE VARCHAR(31) NULL, BILLING_CONTACT_BIRTHDAY date NULL, BILLING_CONTACT_COMPANY VARCHAR(255) NULL, BILLING_CONTACT_CONTACTTYPE INT NULL, BILLING_CONTACT_CUSTOMERNUMBER VARCHAR(255) NULL, BILLING_CONTACT_DATEADDED date NULL, BILLING_CONTACT_DELETED BIT(1) DEFAULT 0 NULL, BILLING_CONTACT_DISCOUNT DOUBLE NULL, BILLING_CONTACT_EMAIL VARCHAR(255) NULL, BILLING_CONTACT_FAX VARCHAR(255) NULL, BILLING_CONTACT_FIRSTNAME VARCHAR(255) NULL, BILLING_CONTACT_GENDER INT NULL, BILLING_CONTACT_GLN BIGINT NULL, BILLING_CONTACT_MANDATEREFERENCE VARCHAR(255) NULL, BILLING_CONTACT_MOBILE VARCHAR(255) NULL, BILLING_CONTACT_MODIFIED date NULL, BILLING_CONTACT_MODIFIEDBY VARCHAR(255) NULL, BILLING_CONTACT_NAME VARCHAR(255) NULL, BILLING_CONTACT_NOTE LONGTEXT NULL, BILLING_CONTACT_PHONE VARCHAR(255) NULL, BILLING_CONTACT_RELIABILITY VARCHAR(255) NULL, BILLING_CONTACT_SUPPLIERNUMBER VARCHAR(255) NULL, BILLING_CONTACT_TITLE VARCHAR(255) NULL, BILLING_CONTACT_USENETGROSS SMALLINT NULL, BILLING_CONTACT_USESALESEQUALIZATIONTAX BIT(1) DEFAULT 0 NULL, BILLING_CONTACT_VALIDFROM date NULL, BILLING_CONTACT_VALIDTO date NULL, BILLING_CONTACT_VATNUMBER VARCHAR(255) NULL, BILLING_CONTACT_VATNUMBERVALID BIT(1) DEFAULT 0 NULL, BILLING_CONTACT_WEBSHOPNAME VARCHAR(255) NULL, BILLING_CONTACT_WEBSITE VARCHAR(255) NULL, BILLING_CONTACT_FK_ADDRESS BIGINT NULL, BILLING_CONTACT_FK_ALTERNATECONTACT BIGINT NULL, BILLING_CONTACT_FK_BANKACCOUNT BIGINT NULL, BILLING_CONTACT_FK_CATEGORY BIGINT NULL, BILLING_CONTACT_FK_PAYMENT BIGINT NULL, DELIVERY_ADDRESS_ID BIGINT NULL, DELIVERY_ADDRESS_CITY VARCHAR(255) NULL, DELIVERY_ADDRESS_CITYADDON VARCHAR(255) NULL, DELIVERY_ADDRESS_COUNTRYCODE VARCHAR(255) NULL, DELIVERY_ADDRESS_DATEADDED date NULL, DELIVERY_ADDRESS_DELETED BIT(1) DEFAULT 0 NULL, DELIVERY_ADDRESS_MANUALADDRESS VARCHAR(4096) NULL, DELIVERY_ADDRESS_MODIFIED date NULL, DELIVERY_ADDRESS_MODIFIEDBY VARCHAR(255) NULL, DELIVERY_ADDRESS_NAME VARCHAR(255) NULL, DELIVERY_ADDRESS_STREET VARCHAR(255) NULL, DELIVERY_ADDRESS_VALIDFROM date NULL, DELIVERY_ADDRESS_VALIDTO date NULL, DELIVERY_ADDRESS_ZIP VARCHAR(255) NULL, DELIVERY_CONTACT_ID BIGINT NULL, DELIVERY_CONTACT_DTYPE VARCHAR(31) NULL, DELIVERY_CONTACT_BIRTHDAY date NULL, DELIVERY_CONTACT_COMPANY VARCHAR(255) NULL, DELIVERY_CONTACT_CONTACTTYPE INT NULL, DELIVERY_CONTACT_DATEADDED date NULL, DELIVERY_CONTACT_DELETED BIT(1) DEFAULT 0 NULL, DELIVERY_CONTACT_DISCOUNT DOUBLE NULL, DELIVERY_CONTACT_FIRSTNAME VARCHAR(255) NULL, DELIVERY_CONTACT_GENDER INT NULL, DELIVERY_CONTACT_GLN BIGINT NULL, DELIVERY_CONTACT_MODIFIED date NULL, DELIVERY_CONTACT_MODIFIEDBY VARCHAR(255) NULL, DELIVERY_CONTACT_NAME VARCHAR(255) NULL, DELIVERY_CONTACT_NOTE LONGTEXT NULL, DELIVERY_CONTACT_TITLE VARCHAR(255) NULL, DELIVERY_CONTACT_VALIDFROM date NULL, DELIVERY_CONTACT_VALIDTO date NULL, DELIVERY_CONTACT_WEBSHOPNAME VARCHAR(255) NULL, DELIVERY_CONTACT_WEBSITE VARCHAR(255) NULL, DELIVERY_CONTACT_FK_ADDRESS BIGINT NULL, CONSTRAINT PK_TMP_CONTACTS_WITH_ADDRESSES PRIMARY KEY (BILLING_ADDRESS_ID))]
Mit latin1 bekomme ich Version 2.0.5 gestartet aber nachdem das ganze mit der beta wieder kommt solltet ihr euch das ganze anschauen.
Moin fleixi, danke für den Tip. ich hab damit auch schon mal gekämpft...
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo zusammen,
bei mir leider das gleiche Problem mit Version 2.0.5, MariaDB 10.3.22 direkt während dem initialen Erzeugen der DB.
Caused by: liquibase.exception.DatabaseException: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs [Failed SQL: ALTER TABLE `fakturama`.`FKT_PAYMENT` MODIFY `PAIDTEXT` VARCHAR(4096)]
Es liegt ja eindeutig an der zu großen Tabelle 'FKT_PEYMENT'. Gibt es dazu schon eine Lösung? Wo kann ich evtl. die Update-Scripte bearbeiten, sodass die Erzeugung der DB durchläuft?
Danke für Eure Mühe!
Oliver
Moin, das hab ich in der 2.1.0 behoben.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?