Ist die Datenbank v...
 
Benachrichtigungen
Alles entfernen

Ist die Datenbank von einem anderen Prozess geöffnet?

11 Beiträge
5 Benutzer
1 Reactions
1,954 Aufrufe
(@eikko)
Active Member
Beigetreten: vor 9 Jahren
Beiträge: 14
Topic starter   [#2957]

Hallo alle zusammen,
vielleicht kann mir ja jemand helfen.

Ich habe eine bestehende Datenbank Vers. 2.0.x die ich auf einem neuen WIN10-PC mit Fakturama Vers. 2.1.1 in Betrieb nehmen möchte.

Fakturama läßt sich starten,
im Splasch-Screen wird eine längere Zeit "checking database" angezeigt,
zum Schluß kommt aber dann die Meldung:
"Keine Verbindung mit Datenbank möglich. Ist die Datenbank von einem anderen Prozess geöffnet?"

Hab das schon mit der aktuellen Datenbank als auch mit einem Backup probiert, es kommt immer der gleiche Fehler.

Hat jemand einen Tip an was das liegen könnte?

Grüße eikko



   
Zitat
(@eikko)
Active Member
Beigetreten: vor 9 Jahren
Beiträge: 14
Topic starter  

Keiner eine Idee?

Wie ist denn der empfohlenen Weg von einem WIN7, Vers. 2.0.x
auf ein WIN10, Vers. 2.1.1 umzuziehen?

Grüße eikko



   
AntwortZitat
 GuHa
(@guha)
Active Member
Beigetreten: vor 5 Jahren
Beiträge: 12
 

An die Frage möchte ich mich auch gleich mal dranhängen.

Ich habe ein frisch aufgesetztes Kubuntu 20.04 und Java 11 und das gleiche Problem.

Bevor das Problem auftrat ließ sich das Programm starten. Als ich die erste Rechnung geschrieben habe, trat bei der Eingabe des Preises des ersten Artikels ein Fehler auf und die Anwendung fuhr fest.

Inzwischen habe ich den ganzen Tag damit zugebracht, alles zum Laufen zu bekommen zu wollen und ich muß dringend Rechnungen und Angebote schreiben.

Langsam macht sich Frust breit. ? 

Im Anhang ein Screenshot der Fehlermeldung.



   
AntwortZitat
 GuHa
(@guha)
Active Member
Beigetreten: vor 5 Jahren
Beiträge: 12
 

Moin, liest hier noch jemand mit?



   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

Hallo @guha!

Ja es wird schon von einigen Leuten mit gelesen, es findet sich nur leider nicht immer die Zeit gleich jedem zu antworten.
Besonders Ralf nutzt seine Zeit eher um am Code zu arbeiten und braucht daher mit Antworten manchmal etwas länger.
Aber es wird versucht hier so gut als möglich zu helfen.

Ist Dein Problem durch das von Dir im Post [1] beschriebene Vorgehen gelöst worden?

LG
Jürgen

 

[1] https://www.fakturama.info/community/postid/17012/


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
 GuHa
(@guha)
Active Member
Beigetreten: vor 5 Jahren
Beiträge: 12
 

Hallo Jürgen, nein, das war ein anderes Problem, das vor diesem hier auftrat. Anscheinend ist es ein sporadisches Problem, denn manchmal schaffe ich es auch, das Programm zu starten.

Dann kommen allerdings neue Probleme, die ich in einem separaten Thread anfragen wollte. Leider habe ich plötzlich keine Berechtigung mehr, hier Threads zu erstellen. ☹️ 



   
AntwortZitat
Jürgen Bruckner
(@microangelo)
Mitglied
Beigetreten: vor 6 Jahren
Beiträge: 691
 

@guha

Veröffentlicht von: @guha

Leider habe ich plötzlich keine Berechtigung mehr, hier Threads zu erstellen. ☹️ 

Das tut mir leid, ich werde Ralf (@rheydenr) über dieses Problem informieren, anscheinend macht Wordpress wieder mal Probleme.
Bitte um etwas Geduld!

LG
Jürgen


microangelo
Produktivsysteme:
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, SingleUser
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3c, MariaDB, Java 17, MultiUser
RaspberryPi OS 12 (Bookworm, 64Bit), Fakturama 2.1.3c, MariaDB, Java 17, Multiuser
auf Raspberry Pi 400, 4GB RAM
Testsystem(e):
LinuxMint Debian Edition (LMDE) 6, Fakturama 2.1.3 (Beta), HSQLDB, Java 17
dzt. kein Windows-System zum testen verfügbar
Alpha-Test:
RaspberryPi OS (64Bit), Fakturama 2.1.3, HSQLDB, Java 11
auf Raspberry Pi 4B, 8GB RAM


   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

So, und ein freundliches Hallo an Alle! ?️ 

Nun ist selber (oder zumindest ganz ähnlicher) Fehler bei mir auch angekommen.

Von Gestern auf Heute und ohne Änderung an Installation, Updates oder SQL-Server.

Das Logfile gibt nur folgendes her:

20210429 17:38:22.118 | ERROR | com.sebulli.fakturama.common [ OSGI_BUNDLE ] | Can't show the error message in Error View because no EventBroker is available!
20210429 17:38:22.121 | ERROR | c.s.f.LifecycleManager.checksBeforeStartup:161 | couldn't create or update database!

 

Konsolenausgabe:

WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven
Apr. 29, 2021 5:41:59 NACHM. javax.money.spi.Bootstrap init
INFORMATION: Money Bootstrap: new ServiceProvider set: org.javamoney.osgi.OsgiServiceProvider
Thu Apr 29 17:42:00 CEST 2021 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+
and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the
verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststo
re for server certificate verification.
SQLException: Communications link failure

The last packet successfully received from the server was 156 milliseconds ago.  The last packet sent successfully to the server was 145 milliseconds ago.
SQLState: 08S01
VendorError: 0

Failed to craete the databaze connection: java.sql.SQLException: can't create database connection!

17:42:00.661 [Equinox Log Thread - Equinox Container: 3546da86-80e1-4232-ac4f-134248faa2cb] ERROR com.sebulli.fakturama.common - Can't show the error message i
n Error View because no EventBroker is available!
17:42:00.663 [Equinox Log Thread - Equinox Container: 3546da86-80e1-4232-ac4f-134248faa2cb] ERROR com.sebulli.fakturama.common - couldn't create or update data
base!

 

Screenshot im Anhang...

Das kommt gerade echt zur Unzeit!  ? 

 

Ich suche schon den ganzen Tag nach Lösungen und bin auch schon mit Neuinstallation Fakturama und Datenbank ""Entsperrung" nicht weiter gekommen.

Zuletzt hat immer folgendes ganz gut geholfen:

use FAKTURAMA-DATABASE;
UPDATE DATABASECHANGELOGLOCK SET LOCKED=0, LOCKGRANTED=null, LOCKEDBY=null where ID=1;
exit;

Bitte ebenfalls um Hilfe!

 

Vielen Dank schon mal im Vorraus!!!!!

 

---------------------------------------------------

 

ENTSCHULDIGT BITTE DIE VIELEN EDITS!!!

Sobald Wordpress einen Datenbankbefehl "vermutet" kommt:

Forbidden

You do not have permission to access this document.

- Wieder was gelernt ... ? 


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

Nachtrag:

Habe eben eine neue, leere Datenbank erstellt und mit einer frischen Fakturama Installation eingerichtet.

Das Resultat ist das selbe! ? 

 
Zugriff mit Windows 10 auf den selben Server (andere Datenbank) funktioniert...
 

Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
Andrée
(@it-service)
Trusted Member
Beigetreten: vor 8 Jahren
Beiträge: 74
 

EILMELDUNG

Fehler behoben !!! ? 

OpenJDK 11 deinstalliert und OpenJDK 13 installiert und siehe da es tut wieder!!! 

 

Keine Ahnung warum es aufeinmal nicht mehr mit der Version 11 tat aber nun gut... ? 

 

Gruß

Andrée

 

 

P.S. Ich LIEBE Fakturama einafch !!!


Produktiv-Systeme:
Clients: (K)ubuntu 20.04 LTS (2x stationär & 1x mobil)
Fakturama 2.1.1 per SQLDatenbank über Internet
DB-Server: Debian 10 (Buster) per VirtualBox
Testsysteme:
BananaPi M1 & RaspberryPi 2b+ & 4 als SQL Server, HP ThinClient T610, Oracle VirtualBox, Windows 10 1909 - 21H1


   
AntwortZitat
(@printdaddy)
New Member
Beigetreten: vor 2 Monaten
Beiträge: 1
 

Hallo zusammen,

erstmal sorry für den Necrobump, aber thematisch passt es hierzu am besten und das Problem scheint das gleiche zu sein. Daher lasse ich meine Lösung hier als Infohappen zurück.

Ich bekam dieselbe Fehlermeldung. Das System hatte vorher problemlos funktioniert. Grund war die falsche Java-Version als Standard. Ich musste von  Openjdk 26 auf Openjdk 21 umstellen, seitdem funktioniert es wieder ohne weitere Änderungen.
Der Befehl zum Umstellen (ggf mit sudo) auf Java Version 21 als Standard lautete:

archlinux-java set java-21-openjdk

Mein System:
Manjaro Linux auf Kernel 7.1.4
Fakturama Version: 2.2.0, Build-ID: 20260529-0724
Java-Version: 21.0.11
Interne Datenbank



   
AntwortZitat
Teilen: