Nach der Installation von Version 2.2.0.202503301224 ist keine Verbindung zur Fakturama-Datenbank auf einem MariaDB Server mehr möglich. Die Fehlermeldung lautet:
!SESSION 2025-05-09 17:16:28.615 ----------------------------------------------- eclipse.buildId=2.2.0.202503301224 java.version=17.0.14 java.vendor=Eclipse Adoptium BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE Command-line arguments: -os win32 -ws win32 -arch x86_64 !ENTRY com.sebulli.fakturama.common 4 0 2025-05-09 17:16:33.648 !MESSAGE c.s.f.LifecycleManager.checksBeforeStartup:158|couldn't create or update database!
Auch eine Neukonfiguration der Datenbankverbindung mit einem erfolgreichen Verbindungstest führt nicht weiter. Nach einem Downgrade auf 2.2.0.20241230 läuft die Datenbankverbindung wieder einwandfrei.
Moin, hattest Du zwischenzeitlich mit der Betaversion gearbeitet? Da gab's mal ein Problem mit dem changelog für die Datenbank. Da hat eine Checksumme nicht gestimmt.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
OK, ich kannte diesen Beitrag, mir war jedoch nicht ganz klar, wie man vorgehen muss. Hab das Problem jetzt wie folgt gelöst:
1. Fakturama (neue Version) mit Konsolenausgabe starten:
"C:\Program Files\Fakturama2\jre\bin\java.exe" -jar plugins\org.eclipse.equinox.launcher_1.6.400.v20210924-0641.jar -startup plugins/org.eclipse.equinox.launcher_1.6.400.v20210924-0641.jar --launcher.library plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.2.700.v20221108-1024 -vmargs -DREFRESH_BUNDLES=false -Dorg.eclipse.e4.ui.css.dynamic=true --add-modules=ALL-SYSTEM -DLiquibaseHubMode=off -Dslf4j.provider=logback
2. Die Fehlermeldung zeigt die falschen Checksummen:
Failed to create the database connection: liquibase.exception.CommandExecutionException: liquibase.exception.ValidationFailedException: Validierung war nicht erfolgreich:
Bei 2 ChangeSets stimmt die Prüfsumme nicht mehr mit der Historientabelle überein.
changelog/db.changelog-2.2.xml::20241014-001::boarschti was: 9:1615e63a91bf66dbfc38d380119c43d2 but is now: 9:e6ed1d9f908d2487aec5145df731209b
changelog/db.changelog-2.2.xml::20241014-002::boarschti was: 9:47014b5a17f0f756cc4ba45485669f7a but is now: 9:0ac9e5b32f1a9d7d5f1258e4c6b34e26
3. In der Datenbank in der Tabelle "databasechangelog" und Spalte "MD5SUM" die betroffenen Zeilen identifizieren und die korrekten Checksummen "but is now" eintragen
4. Anschließend startet die neue Fakturama-Version problemlos