Hallo!
Hier läuft unter LinuxMint 19.1
openjdk version "11.0.3" 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+7-Ubuntu-1ubuntu218.04.1)
OpenJDK 64-Bit Server VM (build 11.0.3+7-Ubuntu-1ubuntu218.04.1, mixed mode, sharing
Wenn ich Fakturama2 starten will, tut es das nicht und im logfile finde ich
!SESSION 2019-07-28 10:41:54.194 -----------------------------------------------
eclipse.buildId=2.0.4.
java.version=11.0.3
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Command-line arguments: -os linux -ws gtk -arch x86_64
!ENTRY org.eclipse.osgi.compatibility.state.nl_hu 2 0 2019-07-28 10:42:03.689
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_hu [8]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
!ENTRY org.eclipse.osgi.compatibility.state.nl_uk 2 0 2019-07-28 10:42:03.696
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_uk [14]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
!ENTRY org.eclipse.e4.ui.swt.gtk.nl_ar 2 0 2019-07-28 10:42:03.697
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_ar [467]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
!ENTRY org.eclipse.e4.ui.swt.gtk.nl_it 2 0 2019-07-28 10:42:03.697
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_it [474]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
usw.
Was könnte ich da tun? Was fehlt?
Grüße
Andreas
Hallo Andreas,
Du benötigst Java 8.x
------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.8 | Win10@LAN 20.04| MySQL 5.7.26@UbuntuServer 18.04.3 | QRK
------------------------------------------------------------
Habe jetzt auch java 8 installiert und darauf umgestellt, aber das Programm wirft wohl zuviele Fehler.
$ /usr/share/fakturama2/Fakturama
WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven
[Server@1b1f5012]: Initiating startup sequence...
[Server@1b1f5012]: Server socket opened successfully in 13 ms.
[Server@1b1f5012]: Database [index=0, id=0, db=file:/home/andreas/:fakturama/Database/Database, alias=fakdbneu] opened successfully in 1172 ms.
[Server@1b1f5012]: Startup sequence completed in 1196 ms.
[Server@1b1f5012]: 2019-07-29 09:24:33.177 HSQLDB server 2.4.0 is online on port 9002
[Server@1b1f5012]: To close normally, connect and execute SHUTDOWN SQL
[Server@1b1f5012]: From command line, use [Ctrl]+[C] to abort abruptly
09:24:38.398 [com.sebulli.fakturama.log.LogbackAdapter@10dc7d6] DEBUG com.sebulli.fakturama.common - start DAOs - begin
09:24:39.481 [com.sebulli.fakturama.log.LogbackAdapter@10dc7d6] INFO com.sebulli.fakturama.common - Entering default Preference Initializer
Jul 29, 2019 9:24:39 AM javax.money.spi.Bootstrap init
INFORMATION: Money Bootstrap: new ServiceProvider set: org.javamoney.osgi.OsgiServiceProvider
[EL Info]: 2019-07-29 09:24:40.662--ServerSession(1404108957)--EclipseLink, version: Eclipse Persistence Services - 2.7.1.v20171221-bd47e8f
[EL Severe]: ejb: 2019-07-29 09:24:40.707--ServerSession(1404108957)--java.lang.NullPointerException
09:24:40.794 [com.sebulli.fakturama.log.LogbackAdapter@10dc7d6] ERROR org.eclipse.core.jobs - Can't show the error message in Error View because no EventBroker is available!
09:24:40.843 [com.sebulli.fakturama.log.LogbackAdapter@10dc7d6] ERROR org.eclipse.core.jobs - Während "initDb" ist ein interner Fehler aufgetreten.
javax.persistence.PersistenceException: java.lang.NullPointerException
at org.eclipse.persistence.internal.jpa.EntityManagerSetupImpl.deploy(EntityManagerSetupImpl.java:846) ~[na:na]
Grüße
Moin,
hier ist was mit der Datenbank schiefgegangen. Irgendwie sieht der Verbindungs-Ausdruck auch ziemlich komisch aus:
file:/home/andreas/:fakturama/Database/Database
Steht da wirklich ein Doppelpunkt vor dem "fakturama"? Der eigentliche Fehler tritt dann beim Einrichten der Datenbank auf, evtl. ist das aber auch eine Folge des seltsamen Namens.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
rheydenr schrieb:
-------------------------------------------------------
> Moin,
> hier ist was mit der Datenbank schiefgegangen.
> Irgendwie sieht der Verbindungs-Ausdruck auch
> ziemlich komisch aus:
>
> file:/home/andreas/:fakturama/Database/Database >
> Steht da wirklich ein Doppelpunkt vor dem
> "fakturama"? Der eigentliche Fehler tritt dann
> beim Einrichten der Datenbank auf, evtl. ist das
> aber auch eine Folge des seltsamen Namens.
Ich habe jetzt neu installiert und Fakturama startet. Angezeigt wird
Unable to load page
Problem occurred while loading the URL file://fakturama/Vorlagen/Start/start.html
Die Adresse kann nicht angezeigt werden
Installiert habe ich in das Verzeichnis Fakturama. Da gibt es wohl ein Problem mit der Groß- und Kleinschreibung?
Grüße
Andreas