FAKTURAMA 2.x: Nach...
 
Benachrichtigungen
Alles entfernen

[Gelöst] FAKTURAMA 2.x: Nach Installation mit Fehlermeldung kein Neustart möglich

93 Beiträge
4 Benutzer
0 Reactions
10.7 K Aufrufe
(@nicoletta)
Reputable Member
Beigetreten: vor 12 Jahren
Beiträge: 375
 

Hallo Jörg,
hast Du schon versucht Fakturama mit dem Parameter -clean von der Konsole zu starten?

Viele Grüße
Nicole


------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.8 | Win10@LAN 20.04| MySQL 5.7.26@UbuntuServer 18.04.3 | QRK
------------------------------------------------------------


   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

Ja, das war bereits einer der ersten Versuche (siehe o.a. Ralf's Empfehlung vom 29. Juni 2018 / 07:17 Uhr), hat aber nichts gebracht ... (td)


JöLi.


   
AntwortZitat
(@buchhalterfa)
Estimable Member
Beigetreten: vor 8 Jahren
Beiträge: 231
 

gelöscht



   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

Es ist schon von Vorteil, wenn man richtig lesen und schreiben kann ! Wieso versuchst Du immer wieder, FAKTURAMA über eine PPA zu installieren und nicht die DEB-Datei herunterzuladen und dann mit GDEBI zu installieren ... ? Und hast Du die FAKTURAMA-PPA zuvor überhaupt in den Paketquellen hinterlegt ? Nicht zuletzt - warum stopfst Du Dein System mit verschiedenen JAVA-Versionen voll - eine reicht völlig und mehrere könnten sich gegenseitig behindern ?

Im Übrigen passt Dein Installations-Problem nicht in unser o.a. Thema ... und daher bitte ich Dich, Deine spezielle Problemdiskussion unter einem anderen Thema unterzubringen und wünsche Dir dort damit viel Erfolg ...

> Autor: buchhalterfa
>
> Hallo, wie ein Versuch mit Kubuntu 18.04.1.
>
> Wieder ohne Erfolg.
>
> - Kubuntu 18.04.1 installiert
> - sudo apt-get update
> - sudo apt-get dist-upgrade
> - reboot
> - sudo apt-get install openjdk-8-jdk openjdk-8-demo openjdk-8-doc openjdk-8-jre-headless openjdk-8-source
> - sudo dpkg -i
> - Fakturama startet nicht


JöLi.


   
AntwortZitat
(@buchhalterfa)
Estimable Member
Beigetreten: vor 8 Jahren
Beiträge: 231

   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

Wenn überhaupt, so muss zuerst in der LINUX/UBUNTU-Paketverwaltung die Quelle hinterlegt werden, von der das zu installierende und später laufend zu updatende Programm heruntergeladen wird. Dazu kan man u.a. im Terminal einen ganz speziellen Befehl nutzen:

"sudo add-apt-repository ppa: (hier für FAKTURAMA)"

Die Quelle (Repositority) ist mir für FAKTURAMA aber selber nicht bekannt, wenn's denn überhaupt eine gibt. Ich habe immer die DEB-Datei herunter geladen und dann mit GDEBI völlig problemlos installiert. Und wie das genau geht, habe ich Dir bereits an andere Stelle mehrfach erläutert (siehe auch "FAKTURAMA 2.0.2.1 in Kubuntu 18.04 amd64 installieren") ... ich will mich hier nicht 1000 Mal wiederholen ...

Wenn Du nicht genau so vorgehst, wirst Du weiterhin auf der Strecke bleiben ...

So - und nun bleibe hier bitte mal mit diesem Deinen Installationsproblem endlich wirklich draussen - hier geht es nämlich um ein völlig anderes Thema !


JöLi.


   
AntwortZitat
(@buchhalterfa)
Estimable Member
Beigetreten: vor 8 Jahren
Beiträge: 231
 

für Fakturama gibt es kein ppa.



   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

... und damit haben sich also Deine Bemühungen, FAKTURAMA über den Befehl "sudo apt-get install ... (fakturama)" zu installieren, erledigt :)-D


JöLi.


   
AntwortZitat
(@buchhalterfa)
Estimable Member
Beigetreten: vor 8 Jahren
Beiträge: 231
 

Das wurde nie versucht.



   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

So - habe noch mal Folgendes versucht:

(1) FAKTURAMA2 komplett deinstalliert und dann neu installiert.
(2) FAKTURAMA2 war bei erstem Start völlig leer und gab irgendeine Fehlermeldung, die JAVA betraf (habe ich aber nicht registriert)
(3) FAKTURAMA2 noch mal gestartet und dann ging Datenübernahme mit Konvertierung los
(4) Stamm- und Arbeitsdaten in Stichproben durchgesehen, wurden offenbar komplett übernommen
(5) Lieferanten-Daten gab es bisher nicht, waren daher mit Bestandteil der Kontakt-Daten bzw. jetzt der Kunden-Daten
(6) habe Kunden-Daten in CSV-Datei exportiert und wollte diese teilweilse in den Lieferanten-Stamm re-importieren; mehrere Versuche mit gleicher Meldung fehlgeschlagen:

"Internal Error - Ursache: java.lang.UnsupportetOperationException: The seperator character must be defined !"

So - aber die Separationszeichen wurden bereits beim Export definiert und ich hab's noch mal unter LibreCalc sowie über einen Editor überprüft. Der Re-Import in die Kunden-Stammdaten funktionierte hingegen problemlos ...

Schlussfolgerung: Entweder die Lieferanten-Stammdatei ist anders als die Kunden-Stammdatei strukturiert, und wenn ja - warum (*) ? Oder hier gibt's einen Fehler, der eventuell auch Ursache für den fehlerhaften Neustart sein könnte ...

(*) Unter den Lieferanten gibt's z.B. keine (zusätzliche) Lieferadresse, aber der Lieferanten-Stammsitz (als Adresse) kann ja auch vom Auslieferungslager (als Adresse) entfernt liegen, so dass die Felder für die Lieferadresse bei den Kunden (Debitoren) für die Auslieferungsadresse des Lieferanten (Kreditoren) genutzt werden könnten ... und damit wäre dann die Kunden-Stammdatei zur Lieferanten-Stammdatei wieder ähnlich.

Dennoch: Die Felder sind ja im Kopf-Datensatz eindeutig gekennzeichnet und könnten sich beim Import der Datensätze auch eindeutig interpretieren lassen, wobei Felder, die in der Stammdatei nicht definiert sind, einfach ignoriert werden sollten ...

Naja - ob's nun wirklich hieran liegt, dass sich FAKTURAMA2 nach der Konvertierung ein 2. Mal nicht starten lässt, muss also weiter geprüft werden ...


JöLi.


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Hallo Jörg,
im neuen Release sind die beiden Fehler behoben (Fakturama wird ordentlich beendet und der Import von Lieferantendaten geht auch). Danke für den Hinweis, das war tatsächlich noch ein Fehler.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

Danke für die Info (tu) Wann und wo kann ich die korrekte 64-bit-LINUX-Version downloaden ?

mfG Jörg


JöLi.


   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

Ich habe heute FAKTURAMA-2 (Fakturama_linux_x64_2.0.3.deb) heruntergeladen und nach einer kompletten Datensicherung von FAKTURAMA-1.6.9 installiert. Die bisherigen Stamm- und Arbeitsdaten wurden konvertiert und dann noch einmal gemäß Anweisung bzw. Hinweis reorganisiert. Nach dem Neustart trat der bisherige Fehler aber leider immer noch auf ... :S

"Ein Fehler ist aufgetreten. Informationen hierzu enthält die Protokolldatei /home/joerg/.fakturama2/.metadata/.log."

Beim Start von FAKTURAMA-1, was unter Zugriff auf das bisherige Arbeitsverzeichnis immer noch möglich ist, scheinen weder die bisherigen Stammdaten (Kontakte, Produkte usw.) noch die Arbeitsdaten (Angebote, Lieferscheine, Rechnungen) zu fehlen, aber ein Start von FAKTURAMA-2 ist nicht möglich - es kommt die o.a. Fehlermeldung.

Beim Vergleich von FAKTURAMA-1 mit FAKTURAMA-2 fiel mir auch auf, dass im Verzeichnis ...Dokumente einige ODT- und PDF-Dokumente nicht übernommen worden sind:

- im neuen FAKTURAMA-2-Arbeitsverzeichnis fehlen so einige Rechnungen aus den Jahren 2017 und 2018
- im bisherigen alten FAKTURAMA-1-Arbeitsverzeichnis sind die fehlenden Dokumente noch vorhanden, die anderen aber nicht mehr

Es liegt die Vermutung nahe, dass diese "Löcher" bzw. "Risse" Hinweise geben könnten, wo die Fehler genauer zu suchen sind ...


JöLi.


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Hallo,
wenn bei der Konvertierung irgendwelche Fehler aufgetreten sind sollte das im migInfo.log im Arbeitsverzeichnis protokolliert werden. Ansonsten gibt es für Fehler auch die Datei .log im Userverzeichnis (unter .fakturama). Dort müßte dann auch drinstehen, warum Fakturama nicht startet. Unter Linux ist es oft so, daß die Datenbank nicht korrekt beendet wird. Der Prozeß hängt dann und muß per kill beendet werden.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@dr-listemann)
Mitglied Registered
Beigetreten: vor 13 Jahren
Beiträge: 250
Topic starter  

Das Thema zieht sich mir jetzt einfach schon zu lange hin, so dass ich beschlossen habe, ab 01.01.2019 mit der Version 2.x völlig neu anzufangen und bis 31.12.2018 nur mit der Version 1.9.x zu arbeiten. Ich werde also die Version 2.x neben der Vorgängerversion installieren und alle Stammdaten dort neu einlesen ...

Im Übrigen gab es bei mir mit FAKTURAMA nie Prozesse, die mit "kill" oder "xkill" zwangsweise beendet werden mussten. Vielleicht versuche ich noch mal (nach einer Datensicherung) eine Konvertierung und schaue mir die "migInfo.log" an, aber ich bin da nicht so optimistisch, weil ich selber die Info's kaum interpretieren kann ...

Beste Grüße - Jörg


JöLi.


   
AntwortZitat
Seite 2 / 7
Teilen: