Guten Morgen,
ich bin ein relativ neuer Benutzer von Fakturama. Das Programm bietet die meisten Dinge, die ich als Selbständiger benötige.
Ich hatte hier Linux opensuse 15.4 laufen. Hier funktionierte Fakturama ohne Probleme (nochmals getestet mit einer neuen Installation von 15.4).
Jedoch bekomme ich das Programm unter opensuse 15.6 nicht mehr zum laufen. Weder mit einer "out-of-the-box" Installation noch mit nachinstalliertem Java etc.
Hier die Fehlermeldung:
mgaertne@mg-australia:~> Fakturama
(Fakturama:6356): dbind-WARNING **: 11:13:16.807: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not pro
vided by any .service files
WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven
(java:6380): dbind-WARNING **: 11:13:18.830: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided
by any .service files
Okt. 09, 2024 11:13:19 AM javax.money.spi.Bootstrap init
INFORMATION: Money Bootstrap: new ServiceProvider set: org.javamoney.osgi.OsgiServiceProvider
[Server@5002fde9]: Initiating startup sequence...
[Server@5002fde9]: Server socket opened successfully in 5 ms.
[Server@5002fde9]: Database [index=0, id=0, db=file:/home/users/mgaertne/Database/Database, alias=fakdbneu] opened successfully in 215 ms.
[Server@5002fde9]: Startup sequence completed in 230 ms.
[Server@5002fde9]: 2024-10-09 00:13:19.747 HSQLDB server 2.6.0 is online on port 9001
[Server@5002fde9]: To close normally, connect and execute SHUTDOWN SQL
[Server@5002fde9]: From command line, use [Ctrl]+[C] to abort abruptly
Okt. 09, 2024 11:13:20 AM liquibase.servicelocator
INFORMATION: Cannot load service: liquibase.license.LicenseService: Provider liquibase.license.pro.DaticalTrueLicenseService could not be instantiated
Okt. 09, 2024 11:13:20 AM liquibase.database
INFORMATION: Set default schema name to PUBLIC
Okt. 09, 2024 11:13:20 AM liquibase.lockservice
INFORMATION: Changelog-Protokoll erfolgreich gesperrt.
Okt. 09, 2024 11:13:20 AM liquibase.changelog
INFORMATION: Reading from PUBLIC.DATABASECHANGELOG
Okt. 09, 2024 11:13:20 AM liquibase.lockservice
INFORMATION: Successfully released change log lock
Okt. 09, 2024 11:13:20 AM liquibase.database
WARNUNG: Failed to restore the auto commit to true
[EL Info]: 2024-10-09 11:13:20.797--ServerSession(1439647076)--EclipseLink, version: Eclipse Persistence Services - 2.7.10.v20211216-fe64cd39c3
SWT WebKitGDBus: error creating DBus server Fehler beim Binden an Adresse (GUnixSocketAddress): Datei oder Verzeichnis nicht gefunden
SWT WebKit: error initializing DBus server, dBusServer == 0
libEGL warning: failed to get driver name for fd -1
libEGL warning: MESA-LOADER: failed to retrieve device information
libEGL warning: failed to get driver name for fd -1
Could not determine the accessibility bus address
(Fakturama:6380): GLib-GIO-CRITICAL **: 11:13:22.093: g_dbus_server_get_client_address: assertion 'G_IS_DBUS_SERVER (server)' failed
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f868263ed16, pid=6380, tid=6381
#
# JRE version: OpenJDK Runtime Environment Zulu17.30+15-CA (17.0.1+12) (build 17.0.1+12-LTS)
# Java VM: OpenJDK 64-Bit Server VM Zulu17.30+15-CA (17.0.1+12-LTS, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, linux-amd64)
# Problematic frame:
# C [libswt-gtk-4950r5.so+0x3ed16] Java_org_eclipse_swt_internal_C_strlen+0xf
#
# Core dump will be written. Default location: Core dumps may be processed with "/bin/false" (or dumping to entfernter Link )
#
# An error report file with more information is saved as:
# entfernter Link
Compiled method (n/a) 5251 8157 n 0 org.eclipse.swt.internal.C::strlen (native)
total in heap [0x00007f871acce190,0x00007f871acce508] = 888
relocation [0x00007f871acce2f0,0x00007f871acce320] = 48
main code [0x00007f871acce320,0x00007f871acce500] = 480
oops [0x00007f871acce500,0x00007f871acce508] = 8
Compiled method (n/a) 5252 8157 n 0 org.eclipse.swt.internal.C::strlen (native)
total in heap [0x00007f871acce190,0x00007f871acce508] = 888
relocation [0x00007f871acce2f0,0x00007f871acce320] = 48
main code [0x00007f871acce320,0x00007f871acce500] = 480
oops [0x00007f871acce500,0x00007f871acce508] = 8
#
# If you would like to submit a bug report, please visit:
# entfernter Link
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
----
Auch eine Neuinstallation von Fakturama (rpm -i Installer_Fakturama_linux_x64_2.1.3c.rpm) brachte keine Änderung.
Was mache ich falsch?
Mathias Gärtner
Moin, das hat nicht unbedingt mit Fakturama zu tun, sondern mit den Libs auf Deinem System. Ich finde den Beitrag gerade nicht, aber das wurde hier schon mal diskutiert.
Hier wurde das schon mal diskutiert.
Hi,
danke für den Hinweis und nein, an den Libraries liegt es dan nicht. Alles was es braucht ist ein
mkdir /tmp/SWT-GDBusServer
mit ownership des Users der Fakturama nutzen will (eventuell hilft auch chmod 777).
Voila, es funktioniert.
Danke für die Hilfe!
Mathias
Probier mal bitte die beta 2.2.0 von Fakturama aus. Die alte Version hat bekannte Probleme mit neueren Systemen.