Hallo,
nach einem Update startet Fakturama nicht mehr. Bitte um Unterstützung zur Fehlerbehebung. Hier der Fehler:
########################
WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven
[Server@46a488c2]: Initiating startup sequence...
[Server@46a488c2]: Server socket opened successfully in 3 ms.
[Server@46a488c2]: Database [index=0, id=0, db=file:/home/user/Office/Fakturama/Database/Database, alias=fakdbneu] opened successfully in 487 ms.
[Server@46a488c2]: Startup sequence completed in 491 ms.
[Server@46a488c2]: 2020-05-25 09:20:46.501 HSQLDB server 2.5.0 is online on port 9002
[Server@46a488c2]: To close normally, connect and execute SHUTDOWN SQL
[Server@46a488c2]: From command line, use [Ctrl]+[C] to abort abruptly
11:20:55.538 [main] ERROR liquibase.changelog.ChangeSet - Change Set /changelog/db.changelog-2.1.xml::20190915-176::rheydenreich (generated) failed. Error: integrity constraint violation: foreign key no parent; FK_FKT_CONTACT_FK_CATEGORY table: FKT_CONTACT value: 3 in statement [ALTER TABLE PUBLIC.FKT_CONTACT ADD CONSTRAINT FK_FKT_CONTACT_FK_CATEGORY FOREIGN KEY (FK_CATEGORY) REFERENCES PUBLIC.FKT_CATEGORY (ID) ON UPDATE NO ACTION ON DELETE NO ACTION] [Failed SQL: (-177) ALTER TABLE PUBLIC.FKT_CONTACT ADD CONSTRAINT FK_FKT_CONTACT_FK_CATEGORY FOREIGN KEY (FK_CATEGORY) REFERENCES PUBLIC.FKT_CATEGORY (ID) ON UPDATE NO ACTION ON DELETE NO ACTION]
liquibase.exception.MigrationFailedException: Migration failed for change set /changelog/db.changelog-2.1.xml::20190915-176::rheydenreich (generated):
Reason: liquibase.exception.DatabaseException: integrity constraint violation: foreign key no parent; FK_FKT_CONTACT_FK_CATEGORY table: FKT_CONTACT value: 3 in statement [ALTER TABLE PUBLIC.FKT_CONTACT ADD CONSTRAINT FK_FKT_CONTACT_FK_CATEGORY FOREIGN KEY (FK_CATEGORY) REFERENCES PUBLIC.FKT_CATEGORY (ID) ON UPDATE NO ACTION ON DELETE NO ACTION] [Failed SQL: (-177) ALTER TABLE PUBLIC.FKT_CONTACT ADD CONSTRAINT FK_FKT_CONTACT_FK_CATEGORY FOREIGN KEY (FK_CATEGORY) REFERENCES PUBLIC.FKT_CATEGORY (ID) ON UPDATE NO ACTION ON DELETE NO ACTION]
11:20:55.545 [Equinox Log Thread - Equinox Container: 897c244b-3eb0-41d2-ba7d-841f4332a294] ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available!
11:20:55.545 [Equinox Log Thread - Equinox Container: 897c244b-3eb0-41d2-ba7d-841f4332a294] ERROR com.sebulli.fakturama.common - couldn't create or update database!
########################
########################
!ENTRY com.sebulli.fakturama.common 4 0 2020-05-25 11:17:52.648
!MESSAGE c.s.f.LifecycleManager.checksBeforeStartup:161|couldn't create or update database!
!SESSION 2020-05-25 11:20:43.461 -----------------------------------------------
eclipse.buildId=2.1.0.
java.version=1.8.0_252
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Command-line arguments: -os linux -ws gtk -arch x86_64
!ENTRY com.sebulli.fakturama.common 4 0 2020-05-25 11:20:55.543
!MESSAGE c.s.f.LifecycleManager.checksBeforeStartup:161|couldn't create or update database!
########################
Danke!
Klaus
Mit der Hilfe von Ralf und eigener Bemühungen könnte das Problem jetzt gelöst werden.
In der Tabelle FKT_CONTACT waren noch Einträge vom Testshop vorhanden, welche Verweise auf eine Kategorie FK_CATEGORY "3" hatte, welche aber nicht mehr existierte.
Ich habe jetzt mit einer HSQLDB GUI diese Werte von "3" auf "null" (keine Kategorie) gesetzt. Anschließend konnte das Update durchgeführt werden, bzw. Fakturama konnte wieder gestartet werden.
Ralf meinte noch, daß die Datenbereinigung in der nächsten Version überarbeitet werden wird.
@Ralf
Vielen Dank für die schnelle Unterstützung und die neue Version!