Hallo in die Runde,
Fakturama 2.04 (auf Ubuntu) startet nicht mehr mit der Fehlermeldung:
15:15:23.435 [com.sebulli.fakturama.log.LogbackAdapter@f1cdb6f4] ERROR com.sebulli.fakturama.common - couldn't create or update database!
Etwas weiter oben steht dann:
[Server@1f85ffd1]: To close normally, connect and execute SHUTDOWN SQL [Server@1f85ffd1]: From command line, use [Ctrl]+[C] to abort abruptly liquibase.exception.LockException: Could not acquire change log lock. Currently locked by fd00:0:0:0:c1cf:e510:5e8a:731e%wlp1s0b1 (fd00:0:0:0:c1cf:e510:5e8a:731e%wlp1s0b1) since 26.08.19 09:33
Das scheint wohl ein bekanntes Problem mit Liquibase zu sein. Die Lösungsempfehlung ist hier wohl in der DB Tabelle DATABASECHANGELOCK "LOCKED" auf false zu setzen. Nur wie komme ich per SQL an die DB? Gibt es noch eine andere Möglichkeit den "Lock" zurückzusetzen?
Update: Per HSQL Database Manager kann ich mich nun zur Datenbank verbinden. Nur finde ich die Tabelle mit dem Lock nicht... 🙁
LG
Olaf
Moin,
die Tabelle heißt DATABASECHANGELOGLOCK. Du brauchst aus dem Database.script nur diese Zeile rauszulöschen:
INSERT INTO DATABASECHANGELOGLOCK VALUES(1,hier steht noch irgendwas anderes)
Dann sollte es wieder funktionieren.
Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?
Hallo Ralf,
Danke für die schnelle Antwort.
Nur gibt es diese Zeile in meiner database.script nicht. Hier der Inhalt der Datei:
SET DATABASE UNIQUE NAME HSQLDB6CD383D7D7 SET DATABASE GC 0 SET DATABASE DEFAULT RESULT MEMORY ROWS 0 SET DATABASE EVENT LOG LEVEL 0 SET DATABASE TRANSACTION CONTROL LOCKS SET DATABASE DEFAULT ISOLATION LEVEL READ COMMITTED SET DATABASE TRANSACTION ROLLBACK ON CONFLICT TRUE SET DATABASE TEXT TABLE DEFAULTS '' SET DATABASE SQL NAMES FALSE SET DATABASE SQL REFERENCES FALSE SET DATABASE SQL SIZE TRUE SET DATABASE SQL TYPES FALSE SET DATABASE SQL TDC DELETE TRUE SET DATABASE SQL TDC UPDATE TRUE SET DATABASE SQL CONCAT NULLS TRUE SET DATABASE SQL UNIQUE NULLS TRUE SET DATABASE SQL CONVERT TRUNCATE TRUE SET DATABASE SQL AVG SCALE 0 SET DATABASE SQL DOUBLE NAN TRUE SET FILES WRITE DELAY 500 MILLIS SET FILES BACKUP INCREMENT TRUE SET FILES CACHE SIZE 10000 SET FILES CACHE ROWS 50000 SET FILES SCALE 32 SET FILES LOB SCALE 32 SET FILES DEFRAG 0 SET FILES NIO TRUE SET FILES NIO SIZE 256 SET FILES LOG TRUE SET FILES LOG SIZE 50 CREATE USER SA PASSWORD DIGEST 'd41d8cd98f00b204e9800998ecf8427e' ALTER USER SA SET LOCAL TRUE CREATE SCHEMA PUBLIC AUTHORIZATION DBA ALTER SEQUENCE SYSTEM_LOBS.LOB_ID RESTART WITH 1 SET DATABASE DEFAULT INITIAL SCHEMA PUBLIC GRANT USAGE ON DOMAIN INFORMATION_SCHEMA.SQL_IDENTIFIER TO PUBLIC GRANT USAGE ON DOMAIN INFORMATION_SCHEMA.YES_OR_NO TO PUBLIC GRANT USAGE ON DOMAIN INFORMATION_SCHEMA.TIME_STAMP TO PUBLIC GRANT USAGE ON DOMAIN INFORMATION_SCHEMA.CARDINAL_NUMBER TO PUBLIC GRANT USAGE ON DOMAIN INFORMATION_SCHEMA.CHARACTER_DATA TO PUBLIC GRANT DBA TO SA SET SCHEMA SYSTEM_LOBS INSERT INTO BLOCKS VALUES(0,2147483647,0)
Und SELECT * FROM INFORMATION_SCHEMA.TABLES; ergibt folgende Tabellenliste, die besagte Tabelle taucht da nicht auf. Irgendwie steh ich auf dem Schlauch...
Hab's gefunden und soweit scheint alles zu funktionieren.
Danke!
LG
Olaf