0153: Error saving ...
 
Benachrichtigungen
Alles entfernen

0153: Error saving dataset bei Angeboten und Auftragsbestätigungen mit mehr als 51 Artikeln, Version 1.5.4

10 Beiträge
2 Benutzer
0 Reactions
1,050 Aufrufe
(@Joerg)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 11
Topic starter   [#166]

Hallo,

nachdem im Bugtrackingsystem seit 26.10. so gar keine Reaktion kommt, versuche ich es hier noch einmal, bevor ich gezwungen bin umzusteigen...

Beschreibung des Fehlers:
Beim Versuch, ein Angebot und auch eine Auftragsbestätigung zu speichern, kommt die Fehlermeldung "Error saving dataset " sobald der 52. Artikel dazukommt. Wird der Artikel 52 wieder gelöscht und irgendeine Änderung vorgenommen, kann dann auch wieder mit 51 Artikel gespeichert werden.

Besonders ärgerlich: Man kann ein komplexes Angebot (hier: rund 100 Positionen) erstellen und auch drucken, aber beim Speichern kommt dann erst die Fehlermeldung.
Somit habe ich wohl wissend, dass die Arbeit am nächsten Tag für die Katz' ist, ein Angebot fertig gemacht und verschickt und ohne Chance zu speichern beendet. Bei der nächsten Änderung gebe ich alles wieder ab Pos. 52 neu ein :-((

Fakturama-Version 1.5.4
Der Fehler tritt bei open Suse 12.1 64Bit und bei Win7 Prof. 32Bit gleichermaßen auf (identisches Arbeitsverzeichnis)
Ebenso tritt der Fehler bei einem komplett neu aufgesetztem Win7-System mit identischem Arbeitsverzeichnis auf.

Any ideas???



   
Zitat
 jens
(@jens)
Mitglied
Beigetreten: vor 14 Jahren
Beiträge: 15
 

Aus dem Log-file geht hervor, das ein string irgendwie abgeschnitten wird. Fehler so nicht nachvollziehbar. Kann man die (abgespeckte) Datenbank bekommen, dann könnnte man das mal debuggen?



   
AntwortZitat
(@Joerg)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 11
Topic starter  

Hallo,

die Datenbank enthält Kundendaten, insbesondere private Kontaktdaten und auch Infos zum Zahlungsverhalten. Das kann ich nicht einfach so rausgeben, und schon gar nicht in einem Forum zum Download.
Was bedeutet denn "abgespeckt"? Ich kann sicherlich so ziemlich alles außer Kundendaten bereitstellen. Und welche Projekte ich bei welchem Kunden zu welchem Preis gemacht habe, interessiert evtl. auch den Mitbewerber. Häufig sind die Angebote deutlich 4stellig und werden halt auch ausgeschrieben... Ich möchte dazu gerade in der Wachstumsphase so einige Internas ebenfalls ungern in's Netz stellen.
Was müsste ich also machen, damit die DB anonymisiert wird und trotzdem sinnvoll debuggt werden kann?

besten Dank für die Mühe



   
AntwortZitat
 jens
(@jens)
Mitglied
Beigetreten: vor 14 Jahren
Beiträge: 15
 

Das meine ich mit abgespeckt. Eine Kopie der DB anlegen mit max. den Daten, um den Fehler nachzuvollziehen. Kunden können wahrscheinlich komplett entfallen, da es ja wohl allen auftritt?
Bei mir tritt der Fehler nämlich mit 52 Artikel in einem Angebot nicht auf.



   
AntwortZitat
(@Joerg)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 11
Topic starter  

OK, ich habe vorsichtshalber noch einmal verifiziert: neuer Kunde Max Mustermann, neues Angebot, gleicher Fehler.
Vermute ich richtig, dass Database.properties und Database.script die notwendigen Dateien sind?



   
AntwortZitat
 jens
(@jens)
Mitglied
Beigetreten: vor 14 Jahren
Beiträge: 15
 

genau, das sollte reichen. Vielleicht geht auch eine direkte email an mich (über PM)?



   
AntwortZitat
(@Joerg)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 11
Topic starter  

you have PM-Mail... 😉



   
AntwortZitat
 jens
(@jens)
Mitglied
Beigetreten: vor 14 Jahren
Beiträge: 15
 

Ich habe den Fehler gefunden: Die Ursache ist eine Variable 'items' in der Tabelle 'documents', die zu kurz definiert ist (Datei /com.sebulli.fakturama/src/com/sebulli/fakturama/data/DataSetDocument.java, Zeile 194).
Die Länge ist auf 256 Zeichen begrenzt. In der Variablen werden, durch Komma getrennt, die Artikelpositionen abgespeichert. Wenn man das Feld erweitert (z.B. auf Typ TEXT mit 32768 Zeichen), klappt alles.

Leider ist mir das ganze Verfahren nicht klar, wie man so eine Fehlerbehebung jetzt veröffentlichen kann.

Ich stelle die Frage mal in das Forum zurück und hoffe, dass Gerd noch reagiert.



   
AntwortZitat
(@Joerg)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 11
Topic starter  

Vielen Dank für die Info, es bleibt also spannend...



   
AntwortZitat
(@Joerg)
Active Member
Beigetreten: vor 15 Jahren
Beiträge: 11
Topic starter  

Hallo Jörg,
das Problem wurde vor einigen Tagen gefixt:
http://code.google.com/p/fakturama/source/detail?r=603 [^]

Es gibt allerdings noch keine neue Version.
gerd
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Diese Antwort im Bugtrackingsystem ist 2 Monate her, es gibt immer noch keine neue Version. 🙁

Ich bin dann mal weg und arbeite zukünftig mit JTL...



   
AntwortZitat
Teilen: