Release Candidate
 
Benachrichtigungen
Alles entfernen

Release Candidate

224 Beiträge
27 Benutzer
0 Reactions
20.2 K Aufrufe
(@grnoom)
Trusted Member
Beigetreten: vor 10 Jahren
Beiträge: 56
 

Spenser schrieb:
-------------------------------------------------------
> Spenser schrieb:
> --------------------------------------------------
> -----
> > Mac OS: beim ersten Start wird gemeldet, dass
> die
> > Anwendung defekt ist und nicht gestartet werden
> > kann.
> >
> > Kann also nicht weiter testen.
>
>
> Ich habs nochmal auf verschiedene Arten
> heruntergeladen. Immer das gleiche Ergebnis. Kann
> nicht gestartet werden weil angeblich defekt.

Also ich habe keine Probleme beim Starten. MacOS 10.12.6 & RC5 ..
bin zwar noch nicht zum testen gekommen aber starten kann ich es ohne Fehlermeldung.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
Topic starter  

Mir ist noch was eingefallen. Wenn Du es installiert hast, kannst Du es ja auch über die Konsole starten. Öffne mal bitte ein Terminal und gib dort "open /Applications/Fakturama2.app" ein. Manchmal kommen dann noch irgendwelche Ausschriften auf dem Bildschirm. Ansonsten kannst Du auch mal in die Datei ~/.fakturama2/.metadata/.log reinschauen. Da könnte auch noch was Interessantes stehen.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@pcheld24)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 44
 

Hallo Ralf,

das komische ist, wenn ich meine Altdaten importiere, sind viele der von mir
beschriebenen Probleme tatsächlich nicht da.
» Kundennummer geht
» ....... etc..
Aber es sind nur die Daten bis zum 20.12.2016 importiert worden ...?

Wenn ich jedoch eine saubere installation mache, treten all die beschriebenen Probleme auf.
Ich habe das gerade noch einmal mit der neuesten Java 64 Version getestet.

Dann habe ich heute Morgen versucht das Ganze mit Mysql laufen zu lassen, das ist leider immer abgestürzt.
Die Tabellen wurde angelegt aber das war es auch 🙁

Ich weiss ja nicht ob du Zeit und Lust hast, dann könnte ich dir das mal per Teamviewer Zeigen.

Gruß
Axel



   
AntwortZitat
(@Spenser)
Eminent Member
Beigetreten: vor 11 Jahren
Beiträge: 32
 

Es muss was mit dem einen Rechner von mir zu tun haben.
Auf dem anderen Rechner funktioniert der Download völlig problemlos.

Ich vergleiche mal die Systeme.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
Topic starter  

Hallo zusammen,
hier ist der nächste Release Candidate:

Linux 32bit
Mac OS X
Linux 64bit
Windows 32bit
Windows 64bit

Fehlerbehebungen in v2.0 RC6
+ DOCUMENT.VESTINGPERIOD.END und DOCUMENT.VESTINGPERIOD.START eingeführt
+ YOURCOMPANY.TAXNR eingeführt
- Artikelnummer hat keine Vorgabe ==> gab's in der alten Version auch nicht.
+ neuer Debitor hat keine Nummer, wenn vorher keine Datenübernahme erfolgte
+ Texte löschen funktioniert nicht
+ Bemerkungstext wird x-mal in die Bemerkungsfelder übernommen, wenn man ihn über die Textauswahl einfügt
+ Feld "Beschreibung" ist in der Erfassungsmaske beim ersten Aufruf nicht sichtbar
+ Spaltenbreiten lassen sich nicht sinnvoll einstellen
+ alternierende Tabellenzeilenhintergründe funktionieren nach dem Verschieben einer Zeile nicht
+ Löschen von Artikeln aus der Erfassungsmaske funktioniert unter bestimmten Umständen nicht
- [nicht mehr nachstellbar] beim Verschieben von Artikeln in der Erfassungsmaske wird manchml nicht neu durchnumeriert
+ [nicht nachstellbar] Beschreibungsfenster kann mehrfach geöffnet werden
+ ändert man im Feld "Anzahl" oder "Beschreibung" etwas und drückt das "Löschen"-Icon, ohne aus dem Feld herauszugehen, wird die Zeile gelöscht, der Text des aktuell geänderten Feldes bleibt aber stehen
+ beim Drucken von Aufträgen oder Auftragsbestätigungen kommt ein Fehler, daß das Dokument nicht erzeugt werden konnte (falls man in einer neuen Umgebung ohne importierte Daten arbeitet)
+ Ausgabe- und Einnahmebelege lassen sich nicht löschen
+ neuer Einnahmebeleg kann nicht über (+) erstellt werden
+ Übersicht Einnahmebelege wird beim Speichern nicht aktualisiert
+ ein führender "/" am Anfang einer Kategorie löst einen Fehler aus
+ Wenn man auf Neu erzeugen --> "Neuer Debitor" klickt, öffnet sich noch mal ein Menü --> Neuer Kreditor/ Neuer Debitor
+ Im Feld Anzahl die Taste "Entfernen" und dann "Enter" gedrückt führt zu einer Exception
+ Formatierung von 0-Werten war nicht korrekt
+ Wenn ein Space " " in dem Feld steht ist die Meldung: "keine Zahl"
==> das ist korrekt so!
+ Einordnung in falsche Kategorie bei Lieferscheinen
+ Baumansicht wird nicht aktualisiert bei Dokumentliste
+ Fehler bei Verwendung von manuellen Adressen in Lieferscheinen
+ Rechnung aus Lieferschein übernimmt Adresse nicht (Rechnungs- und
Lieferadresse vertauscht)
+ Klick auf Lieferschein im Übersichtsfenster führt zu Fehler
+ beim Versuch, ein weiteres Folgedokument zu erzeugen, kommt eine Warnung
+ Performance-Verbesserung beim Start
+ Info beim Export, wenn keine Daten vorhanden sind
+ Fehler bei leerer Anzahl (im Erfassungsdialog) oder bei den Rabatten
oder Preisen
+ Löschen von Debitoren und Kreditoren aus der Übersichtsliste
funktioniert nicht
+ "neuer Kontakt" unterscheidet nicht zwischen Kreditor und Debitor
+ neu erstellte Steuersätze, Texte o.ä. werden beim Klick in der
Übersichtsliste in einem weiteren Fenster geöffnet, obwohl das "alte"
Fenster noch offen ist.
+ Speichern eines neuen Steuersatzes funktioniert nicht gleich beim
ersten Mal, sondern liefert einen Fehler. Erst beim zweiten Klick auf
Speichern funktioniert es.
+ beim Umschalten der Rechnungsart (brutto / netto) im Rechnungseditor werden die (manuell eingegebenen)
Versandkosten kontinuierlich verringert bzw. erhöht
+ im Versandkosteneditor stimmen die Beträge nicht, wenn man zwischen den einzelnen MwSt.-Berechnungsarten wechselt
+ beim Laden einer bestehenden Versandart wird der Editor nicht korrekt aufgebaut (Felder werden nicht korrekt dargestellt)
+ Toolbar-Icons für neue Ausgabebelege und Proforma-Rechnungen sind falsch
+ legt man eine neue Artikelzeile an und klickt in das Rabatt-Feld, kommt beim Verlassen des Feldes eine Exception
+ das Ausfüllen von Paketscheinen funktioniert nicht (die Webformulare werden nicht ausgefüllt bei manuell eingegebenen Adressen)
+ beim Ausfüllen des Paketscheins wird immer dasselbe Dokument als Quelle verwendet
+ nach dem Schließen des Paketdienst-Fensters und der erneuten Auswahl des Paketdienst-Icons gibt es eine Exception
+ der UPS-Paketdienst fehlt in der Paketdienstliste
+ Icon im Paketservice-Browser fehlt (im Tab)
+ neuer Kunde wurde trotz nicht passender Kundennummer gespeichert
+ nach dem erstmaligen Speichern eines Editors und anschließendem Ändern weiterer Felder werden diese Änderungen nicht übernommen
+ Versandarten: ändert man den Versandkosten-Wert, wird dieser nicht gespeichert. Wird nur der Wert geändert, kann man gar nicht speichern (kein Sternchen)
+ Versandarten: Bruttowert wird nicht gespeichert, wenn man dies ausgewählt hat
+ Versandarten: Übersichtsfenster wird nach dem Speichern nicht aktualisiert
+ Kontakte/Kreditoren: Übersichtsfenster wird nach dem Speichern nicht aktualisiert
+ Suchfeld im Übersichtsfenster überarbeitet
+ Menüpunkt "Perspektive zurücksetzen" fehlt
+ Eingabeelemente waren teilweise zu klein auf der Rechnungserfassungsmaske (Comboboxen, Spinner)
+ Beträge werden im Produkteditor nicht richtig dargestellt (größere Beträge werden im Nettofeld einfach abgeschnitten, kein €-Zeichen, keine Tausendertrennung)


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@moped)
Mitglied Registered
Beigetreten: vor 14 Jahren
Beiträge: 648
 

Hallo Ralf,

ich kann die Linux 64bit Version nicht starten wegen einem Datenbankfehler:

[Server@46c3a14d]: From command line, use [Ctrl]+[C] to abort abruptly
INFO 29.09.17 08:04: liquibase: Successfully acquired change log lock
INFO 29.09.17 08:04: liquibase: Reading from PUBLIC.DATABASECHANGELOG
SEVERE 29.09.17 08:04: liquibase: /changelog/db.changelog-master.xml: /changelog/db.changelog-2.0.xml::1489873806573-1::rheydenr (generated): Change Set /changelog/db.changelog-2.0.xml::1489873806573-1::rheydenr (generated) failed. Error: object name already exists: FKT_ADDRESS in statement [CREATE TABLE "PUBLIC"."FKT_ADDRESS" ("ID" BIGINT GENERATED BY DEFAULT AS IDENTITY (START WITH 1) NOT NULL, "CITY" VARCHAR(255), "CITYADDON" VARCHAR(255), "COUNTRYCODE" VARCHAR(255), "DATEADDED" date, "DELETED" BOOLEAN DEFAULT FALSE, "MANUALADDRESS" VARCHAR(255), "MODIFIED" date, "MODIFIEDBY" VARCHAR(255), "NAME" VARCHAR(255), "STREET" VARCHAR(255), "VALIDFROM" date, "VALIDTO" date, "ZIP" VARCHAR(255), CONSTRAINT "PK_FKT_ADDRESS" PRIMARY KEY ("ID"))] [Failed SQL: CREATE TABLE "PUBLIC"."FKT_ADDRESS" ("ID" BIGINT GENERATED BY DEFAULT AS IDENTITY (START WITH 1) NOT NULL, "CITY" VARCHAR(255), "CITYADDON" VARCHAR(255), "COUNTRYCODE" VARCHAR(255), "DATEADDED" date, "DELETED" BOOLEAN DEFAULT FALSE, "MANUALADDRESS" VARCHAR(255), "MODIFIED" date, "MODIFIEDBY" VARCHAR(255), "NAME" VARCHAR(255), "STREET" VARCHAR(255), "VALIDFROM" date, "VALIDTO" date, "ZIP" VARCHAR(255), CONSTRAINT "PK_FKT_ADDRESS" PRIMARY KEY ("ID"))]
INFO 29.09.17 08:04: liquibase: /changelog/db.changelog-2.0.xml::1489873806573-1::rheydenr (generated): Successfully released change log lock
liquibase.exception.MigrationFailedException: Migration failed for change set /changelog/db.changelog-2.0.xml::1489873806573-1::rheydenr (generated):
 Reason: liquibase.exception.DatabaseException: object name already exists: FKT_ADDRESS in statement [CREATE TABLE "PUBLIC"."FKT_ADDRESS" ("ID" BIGINT GENERATED BY DEFAULT AS IDENTITY (START WITH 1) NOT NULL, "CITY" VARCHAR(255), "CITYADDON" VARCHAR(255), "COUNTRYCODE" VARCHAR(255), "DATEADDED" date, "DELETED" BOOLEAN DEFAULT FALSE, "MANUALADDRESS" VARCHAR(255), "MODIFIED" date, "MODIFIEDBY" VARCHAR(255), "NAME" VARCHAR(255), "STREET" VARCHAR(255), "VALIDFROM" date, "VALIDTO" date, "ZIP" VARCHAR(255), CONSTRAINT "PK_FKT_ADDRESS" PRIMARY KEY ("ID"))] [Failed SQL: CREATE TABLE "PUBLIC"."FKT_ADDRESS" ("ID" BIGINT GENERATED BY DEFAULT AS IDENTITY (START WITH 1) NOT NULL, "CITY" VARCHAR(255), "CITYADDON" VARCHAR(255), "COUNTRYCODE" VARCHAR(255), "DATEADDED" date, "DELETED" BOOLEAN DEFAULT FALSE, "MANUALADDRESS" VARCHAR(255), "MODIFIED" date, "MODIFIEDBY" VARCHAR(255), "NAME" VARCHAR(255), "STREET" VARCHAR(255), "VALIDFROM" date, "VALIDTO" date, "ZIP" VARCHAR(255), CONSTRAINT "PK_FKT_ADDRESS" PRIMARY KEY ("ID"))]
	at liquibase.changelog.ChangeSet.execute(ChangeSet.java:605)
	at liquibase.changelog.visitor.UpdateVisitor.visit(UpdateVisitor.java:51)
	at liquibase.changelog.ChangeLogIterator.run(ChangeLogIterator.java:79)
	at liquibase.Liquibase.update(Liquibase.java:214)
	at liquibase.Liquibase.update(Liquibase.java:192)
	at com.sebulli.fakturama.dbservice.impl.DbUpdateService.updateDatabase(DbUpdateService.java:73)
	at com.sebulli.fakturama.LifecycleManager.checksBeforeStartup(LifecycleManager.java:150)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
	at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:305)
	at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:233)
	at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:107)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.lambda$0(E4Application.java:239)
	at java.util.Optional.ifPresent(Optional.java:159)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:235)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:149)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1472)
Caused by: liquibase.exception.DatabaseException: object name already exists: FKT_ADDRESS in statement [CREATE TABLE "PUBLIC"."FKT_ADDRESS" ("ID" BIGINT GENERATED BY DEFAULT AS IDENTITY (START WITH 1) NOT NULL, "CITY" VARCHAR(255), "CITYADDON" VARCHAR(255), "COUNTRYCODE" VARCHAR(255), "DATEADDED" date, "DELETED" BOOLEAN DEFAULT FALSE, "MANUALADDRESS" VARCHAR(255), "MODIFIED" date, "MODIFIEDBY" VARCHAR(255), "NAME" VARCHAR(255), "STREET" VARCHAR(255), "VALIDFROM" date, "VALIDTO" date, "ZIP" VARCHAR(255), CONSTRAINT "PK_FKT_ADDRESS" PRIMARY KEY ("ID"))] [Failed SQL: CREATE TABLE "PUBLIC"."FKT_ADDRESS" ("ID" BIGINT GENERATED BY DEFAULT AS IDENTITY (START WITH 1) NOT NULL, "CITY" VARCHAR(255), "CITYADDON" VARCHAR(255), "COUNTRYCODE" VARCHAR(255), "DATEADDED" date, "DELETED" BOOLEAN DEFAULT FALSE, "MANUALADDRESS" VARCHAR(255), "MODIFIED" date, "MODIFIEDBY" VARCHAR(255), "NAME" VARCHAR(255), "STREET" VARCHAR(255), "VALIDFROM" date, "VALIDTO" date, "ZIP" VARCHAR(255), CONSTRAINT "PK_FKT_ADDRESS" PRIMARY KEY ("ID"))]
	at liquibase.executor.jvm.JdbcExecutor$ExecuteStatementCallback.doInStatement(JdbcExecutor.java:301)
	at liquibase.executor.jvm.JdbcExecutor.execute(JdbcExecutor.java:55)
	at liquibase.executor.jvm.JdbcExecutor.execute(JdbcExecutor.java:107)
	at liquibase.database.AbstractJdbcDatabase.execute(AbstractJdbcDatabase.java:1273)
	at liquibase.database.AbstractJdbcDatabase.executeStatements(AbstractJdbcDatabase.java:1255)
	at liquibase.changelog.ChangeSet.execute(ChangeSet.java:568)
	... 31 more
Caused by: java.sql.SQLSyntaxErrorException: object name already exists: FKT_ADDRESS in statement [CREATE TABLE "PUBLIC"."FKT_ADDRESS" ("ID" BIGINT GENERATED BY DEFAULT AS IDENTITY (START WITH 1) NOT NULL, "CITY" VARCHAR(255), "CITYADDON" VARCHAR(255), "COUNTRYCODE" VARCHAR(255), "DATEADDED" date, "DELETED" BOOLEAN DEFAULT FALSE, "MANUALADDRESS" VARCHAR(255), "MODIFIED" date, "MODIFIEDBY" VARCHAR(255), "NAME" VARCHAR(255), "STREET" VARCHAR(255), "VALIDFROM" date, "VALIDTO" date, "ZIP" VARCHAR(255), CONSTRAINT "PK_FKT_ADDRESS" PRIMARY KEY ("ID"))]
	at org.hsqldb.jdbc.JDBCUtil.sqlException(Unknown Source)
	at org.hsqldb.jdbc.JDBCUtil.sqlException(Unknown Source)
	at org.hsqldb.jdbc.JDBCStatement.fetchResult(Unknown Source)
	at org.hsqldb.jdbc.JDBCStatement.execute(Unknown Source)
	at liquibase.executor.jvm.JdbcExecutor$ExecuteStatementCallback.doInStatement(JdbcExecutor.java:299)
	... 36 more
08:04:50.642 [com.sebulli.fakturama.log.LogbackAdapter@5fb65013] ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available!
08:04:50.642 ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available!
08:04:50.644 [com.sebulli.fakturama.log.LogbackAdapter@5fb65013] ERROR com.sebulli.fakturama.common - couldn't create or update database!
08:04:50.644 ERROR com.sebulli.fakturama.common - couldn't create or update database!

Any idea?

Gruß
moped



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
Topic starter  

Hm, ja. Sorry. Ich mußte noch was an der Datenbank drehen, bitte diese und auch das .fakturama2-Verzeichnis nochmal wegputzen.

Info an alle Linux-Nutzer: Es gibt leider unerfreuliche Nachrichten für euch 🙁 Beim Speichern von Produkten, Rechnungen usw. wird zwar gespeichert, das Sternchen für "geändert" bleibt aber im Editor stehen. Das ist derzeit auch nur auf Linux so und hat was mit den verwendeten Bibliotheken zu tun (GTK3). Ich bin dabei, das zu untersuchen, habe dafür aber derzeit keine Lösung. Der Fehler tritt nur auf bei Editoren, die neben den änderbaren auch nicht-änderbare Dropdown-Felder haben (bitte nicht fragen, warum...).
Bei den Kategorie-Dropdownlisten gilt folgendes: Direkt reinklicken geht nicht, man kann aber ins nächste editierbare Feld springen und dann per Umschalt-TAB nach "hinten" springen. Sehr unschön, funktioniert aber erst mal. Ich weiß nicht, ob das nur unter Ubuntu so ist oder auch unter den anderen Linux-Distros. Unter Windows und MacOS ist das kein Problem. Tut mir leid für die Umstände...

Es gibt derzeit auch erst mal nur Tar.Gz für Linux und Zip für die Windows-Community. Bitte in ein eigenes Verzeichnis auspacken. Die Installer baue ich später noch.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
Topic starter  

so, die Installer sind jetzt auch fertig. Ich denke, da ist für jeden was dabei 😉

Linux 32bit Debian Installer
Linux 32bit (TAR.GZ Programmpaket)
Linux 64bit (TAR.GZ Programmpaket)
Linux 64bit Debian Installer
Linux 64bit RPM Installer
Mac OS X Installer
Linux 64bit Installer (Shell)
Windows 32bit
Windows 64bit


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@winnewoerp)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 19
 

Hallo Ralf,

danke für die neue Version.

Hier meine Rückmeldungen (Windows 7 64bit):

- Das hier war mir vorher schon aufgefallen, aber ich hatte vergessen, es zu melden: Bei der "Fakturama Initialisierung" (100% richtig wäre: "Fakturama-Initialisierung" 😉 ) springt nach der Auswahl des Arbeitsverzeichnisses auch die untere Zeile "Arbeitsverzeichnis (alt)" auf den in der oberen Zeile gesetzten Pfad um. Ob das nur ein Anzeigefehler ist oder ob im Hintergrund dann tatsächlich versucht wird, Daten vom neuen ins neue Verzeichnis zu kopieren, kann ich nicht sagen, da ich danach immer vorsichtshalber manuell die untere Zeile erneut auf das richtige alte Arbeitsverzeichnis einstelle.

- Nach dem Neustart, der automatisch nach dem Einstellen des neuen Arbeitsverzeichnisses erfolgt, kommt eine Fehlermeldung, dass ein Fehler aufgetreten sei und Informationen dazu in der Logdatei eingesehen werden können.

- Dabei bleibt es dann leider auch erst einmal, ich komme also im Moment leider nicht weiter. Hier ist die .log-Datei.

Vielleicht ist ja für dich einfach ersichtlich, woran es liegt?

Besten Gruß
winnewoerp


http://www.stadtkreation.de


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
Topic starter  

Seltsam. Ich habe wirklich das Install-Archiv genommen und damit problemlos Fakturama starten können, ohne Fehler. Zum einen werden verschiedene Zusatzmodule nicht gefunden, zum anderen sind irgendwelche Einträge in der Datenbank doppelt. Ich werde noch einbauen, daß der Fehler abgefangen wird. Hattest Du die Datenbank vorher weggeräumt?


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@winnewoerp)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 19
 

Es lag einfach daran, dass ich die .fakturama2-Datei des vorigen RC nicht rechtzeitig weggeschmissen hatte. Auch der oben genannte Fehler beim Einstellen des Arbeitsverzeichnisses taucht nun nicht mehr auf.

Also, nun läuft's. Bestens! Und danke für die Ergänzungen/Korrekturen.

Hier die Rückmeldungen:

- Bei den Adressen der Kontakte taucht nun DE- vor der PLZ und "Deutschland" darunter auf, obwohl ich in den Einstellungen bei den Kontakten angegeben habe, dass "Deutschland,Germany" nicht gesondert angezeigt werden sollen.

Der Rest funktioniert, zumindest das, was ich bei der Rechnungserstellung gerade getestet habe.

Nice to have wäre:

- Keine weiße Schrift auf hellblauen Kopfzeilen oder hellblau markierten Zellen/Bereichen, auch nicht wenn aktiv, da sehr schwer lesbar/kein ausreichender Kontrast.

- Ich bin es von LibreOffice Calc etc. gewöhnt, dass ich bei Dezimalwerten < 1 die führende Null nicht mit eingeben muss, sondern direkt mit dem Komma starten kann für die Eingabe. Das mag Fakturama wohl nicht, lässt das Komma dann einfach weg. Fast hätte ich schon 75 Stunden statt ",75" (Eingabe) bzw. "0,75" (Ausgabe) Stunden in Rechnung gestellt. Lässt sich das also für Fakturama auch einstellen, dass man es so eingeben kann, also ohne die Null zu tippen?

- Scrollverhalten: Benutzt man das Mausrad und kommt dabei aus Versehen über ein Feld, verstellt man sehr leicht Werte, wenn das entsprechende Feld gerade aktiv ist. Lässt sich das irgendwie verhindern?

- Ausblendbarkeit und Verschiebbarkeit von Spalten in der Artikelliste bei Rechnungen

- Einstellung, dass man Leistungsdatum und Auftragsdatum in der Rechnungs-Bearbeitungsansicht ausblenden kann, wenn man mit "Beginn Leistungszeitraum" und "Ende Leistungszeitraum" arbeitet.

Viele Grüße
winnewoerp


http://www.stadtkreation.de


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
Topic starter  

Hallo winnewoerp,
das "DE- " vor der PLZ kommt wegen der Adreßeinstellung. Du kannst das in den Formateinstellugnen für die Adresse ändern.
Die Eingabe ohne führende 0 habe ich noch nicht umgesetzt, aber auch schon vermißt. Werde das vielleicht noch kurzfristig einbauen.
Das Problem mit dem Scrollrad gibt es schon seit Anfang an (auch schon in der alten Version), das ist häßlich, aber ich kann's momentan nicht ändern. Mich stört das auch.
Ausblendbarkeit von Spalten geht noch nicht, ist aber vorgesehen. Verschiebbarkeit von Spalten ebenfalls.
"Leistungsdatum und Auftragsdatum in der Rechnungs-Bearbeitungsansicht ausblenden" muß ich noch mal überlegen wie ich das mache. Ich geb Dir aber recht, daß das noch nicht rund ist.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@Spenser)
Eminent Member
Beigetreten: vor 11 Jahren
Beiträge: 32
 

Unter Mac OS X High Sierra lief auf meinem Rechner die vorhergehende Version noch sehr gut, die jetzige startet und beendet sich nach ein paar Sekunden wieder.



   
AntwortZitat
(@Spenser)
Eminent Member
Beigetreten: vor 11 Jahren
Beiträge: 32
 

Ich hab auch ne Fehlermeldung gefunden:

!ENTRY com.sebulli.fakturama.common 4 0 2017-10-03 19:27:55.867
!MESSAGE couldn't create or update database!
!SESSION 2017-10-03 19:28:02.202 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Framework arguments: -keyring /Users/ritth/.eclipse_keyring
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/ritth/.eclipse_keyring

!ENTRY com.sebulli.fakturama.common 4 0 2017-10-03 19:28:06.619
!MESSAGE couldn't create or update database!
!SESSION 2017-10-03 19:30:03.854 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Framework arguments: -keyring /Users/ritth/.eclipse_keyring
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/ritth/.eclipse_keyring

!ENTRY com.sebulli.fakturama.common 4 0 2017-10-03 19:30:13.676
!MESSAGE couldn't create or update database!

Und noch die error.log:

2316 [com.sebulli.fakturama.log.LogbackAdapter@2687725a] ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available!
2318 [com.sebulli.fakturama.log.LogbackAdapter@2687725a] ERROR com.sebulli.fakturama.common - couldn't create or update database!
2244 [com.sebulli.fakturama.log.LogbackAdapter@46731692] ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available!
2246 [com.sebulli.fakturama.log.LogbackAdapter@46731692] ERROR com.sebulli.fakturama.common - couldn't create or update database!
2236 [com.sebulli.fakturama.log.LogbackAdapter@228cea97] ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available!
2238 [com.sebulli.fakturama.log.LogbackAdapter@228cea97] ERROR com.sebulli.fakturama.common - couldn't create or update database!
3664 [com.sebulli.fakturama.log.LogbackAdapter@46731692] ERROR com.sebulli.fakturama.common - Can't show the error message in Error View because no EventBroker is available!
3668 [com.sebulli.fakturama.log.LogbackAdapter@46731692] ERROR com.sebulli.fakturama.common - couldn't create or update database!



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
Topic starter  

Hallo Spenser, es sieht aus, als ob Du zwar Dein Arbeitsverzeichnis, aber nicht das .fakturama2-Verzeichnis entfernt hättest. Zumindest sieht die Fehlermeldung danach aus. Da steht, daß nicht auf die Datenbank zugegriffen werden kann. Vermutlich weil sie weg ist. Ist das so?


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
Seite 10 / 15
Teilen: