Nur Splashscreen si...
 
Benachrichtigungen
Alles entfernen

Nur Splashscreen sichtbar

10 Beiträge
4 Benutzer
0 Reactions
824 Aufrufe
 a200
(@a200)
Active Member
Beigetreten: vor 9 Jahren
Beiträge: 6
Topic starter   [#2397]

Moin,

ich habe Fakturama 2 installiert. Leider kommt nach dem Splashscreen nichts mehr:

!SESSION 2018-02-04 16:48:23.393 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_161
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY com.sebulli.fakturama.common 4 0 2018-02-04 16:48:28.423
!MESSAGE couldn't create or update database!

Was mache ich falsch?

Danke und LG,
a200.



   
Zitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Hallo a200,
hast Du bei der Installation ein neues Arbeitsverzeichnis angegeben? Das Verzeichnis der Version 2 muß sich vom alten Arbeitsverzeichnis unterscheiden, da hier eine neue Datenbank erstellt wird.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
 a200
(@a200)
Active Member
Beigetreten: vor 9 Jahren
Beiträge: 6
Topic starter  

Ja, das habe ich. Egal was ich eingebe, bekomme ich diese Fehlermeldung.



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

und Du hast auch von allem die 64bit-Version? Java und Fakturama?


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@deGobbis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 25
 

Hallo Ralf,

ich war mal wieder mutig und habe die Version 2.0.0 Stable installiert, Blanko mit MySQL, bekomme den gleichen Fehler beim Neustart.

Interessant ist dabei, das aber Tabellen in die Datenbank geschrieben werden.

Gab es denn Anpassungen, im Bereich Datenbank, zwischen der RC9 und der Stable, denn die RC9 lässt sich installieren.

Gruß Guido


Arch Linux, x86_64, i3-gaps mit Xorg, jre10-openjdk, jre10-openjdk-headless, java-runtime-common


   
AntwortZitat
(@libero2017)
Trusted Member
Beigetreten: vor 9 Jahren
Beiträge: 68
 

Meine Installation ist "Windows", hatte ein ähnliches Problem. (Nur Splashscreen)

Gelöst mit Berechtigung und die richtigen MySQL Einstellungen

Vielleicht hilft das weiter.

Hier meine damalige Lösung

Gaetano


------------------------------------------------------------------------------
Fakturama 2.0.0.1
Windows 7 64bit & Windows 10 - Dokumente auf NAS Synology - MariaDB-Datenbank auf Synology
------------------------------------------------------------------------------


   
AntwortZitat
(@deGobbis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 25
 

Hallo Gaetano,

die Datenbank ist leer, die Installation frisch ohne Datenübernahme, die Zugangsdaten zur Datenbank müssen passen und für den Benutzer habe ich auch Grant-Privilegien eingerichtet, denn es werden ja Tabellen in die Datenbank geschrieben.

Und trotzdem wird mit der Meldung abgebrochen:

!ENTRY com.sebulli.fakturama.common 4 0 ...... 
!MESSAGE couldn't create or update database!

Arch Linux, x86_64, i3-gaps mit Xorg, jre10-openjdk, jre10-openjdk-headless, java-runtime-common


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Hallo zusammen,
ich habe in der Release-Version noch eine kleine Änderung an der Datenbank vorgenommen. Allerdings sollte das eigentlich nicht das Problem sein. Vor einer "frischen" Installation sollte folgendes geprüft werden:

  • .fakturama2-Verzeichnis entfernt?
  • evtl. vorhandenes Fakturama2-Programmverzeichnis entfernt?
  • Datenbank leer (keine Tabellen, nur Datenbank als solches)
  • neues Arbeitsverzeichnis ist ein anderes als das alte aus Versioin 1.x

Ansonsten müssen wir das nochmal bilateral beackern.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@deGobbis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 25
 

Hallo Ralf,

alles gegeben, das .faktorama2 war gelöscht, sowie auch das Fakturama2-Arbeitsverzeichnis.
Die Datenbank war leer und es gibt auch keine 1.x Version mehr.

Nach der Installation konnte ich das Arbeitsverzeichnis angeben, da wurden auch die Vorlagen angelegt (mehr jedoch nicht) und auch die Zugnagsdaten für die Datenbank wurden akzeptiert, es wurden Tabellen angelegt.

Und trotzdem wurde mit der o.g. Meldung, in der Log, abgebrochen.

Gruß Guido


Arch Linux, x86_64, i3-gaps mit Xorg, jre10-openjdk, jre10-openjdk-headless, java-runtime-common


   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Hallo Guido,
die Meldung in dem Logfile ist eigentlich nur, daß die Datenbank nicht angesprochen werden kann. Wenn aber beeits Tabellen angelegt wurden und initial alles befüllt wurde sollten eigentlich nachfolgende Aufrufe auch klappen. Können wir da ggf. mal gemeinsam drüberschauen? Mir erschließt sich das gerade nicht und ich hoffe, daß das ein Einzelfall ist. Ich habe das ja die ganze Zeit während der Entwicklung auch mit einer entfernten Datenbank (MySQL auf NAS) getestet, da ist mir das nicht aufgefallen.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
Teilen: