Fakturama 2.0.5 mit...
 
Benachrichtigungen
Alles entfernen

[Gelöst] Fakturama 2.0.5 mit Heidi SQL startet nicht mehr

9 Beiträge
2 Benutzer
0 Reactions
807 Aufrufe
(@mattheis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 23
Topic starter   [#2689]

Hallo,

ohne (zumindest keine Veränderung an Fakturama 2.0.5 unter WIN 10 und der Heidi SQL) ersichtlichen Grund startet Fakturama nicht mehr. Es kommt das Startbild mit "checking database" und das war es. Das LOG ist (für mich) auch nicht wirklich aussagekräftig.
Weiß hier jemand Rat?

Gruß

Matthias

!SESSION 2020-07-03 16:08:17.211 -----------------------------------------------
eclipse.buildId=2.0.5.
java.version=1.8.0_251
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY com.sebulli.fakturama.common 4 0 2020-07-03 16:08:25.991
!MESSAGE couldn't create or update database!



   
Zitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Moin, das klingt nach einem Lock-Problem. In dem Database.script gibt es eine Zeile, die mit "INSERT INTO DATABASECHANGELOGLOCK..." anfängt. Die müßtest Du mal rauslöschen.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@mattheis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 23
Topic starter  

@rheydenr

Hallo Ralf,

wo finde ich diese Datei / den Eintrag?

Gruß

Matthias



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Die Datei findest Du in Deinem Arbeitsverzeichnis im Unterverzeichnis Database. Dort öffnest Du die Datei Database.script mit einem Texteditor (nicht Word!!!).


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@mattheis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 23
Topic starter  

@rheydenr
Hallo,

leider ist weder das Verzeichniss Database noch eine Datei.script auffindbar ????

Gruß

Mathias



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Arbeitest Du evtl. mit MySQL?


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@mattheis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 23
Topic starter  

@rheydenr

Hallo,

ja, mit Heidi / SQL

Gruß

Matthias



   
AntwortZitat
(@rheydenr)
Forum-Admin Registered
Beigetreten: vor 14 Jahren
Beiträge: 4911
 

Dann schau mal im HeidiSQL nach der Tabelle DATABASECHANGELOGLOCK und lösche dort den Inhalt.


Viele Grüße
Ralf.
Wichtige Infos zum Posten im Forum.
Fehler gefunden?


   
AntwortZitat
(@mattheis)
Eminent Member
Beigetreten: vor 9 Jahren
Beiträge: 23
Topic starter  

@rheydenr
Interessante Sache, die Heidi lies mich nicht ran 🙂
Also neuer Ansatz,warum kein Zugriff.
Der SQL-Server war inaktiv und musste manuell gestartet werden. (Kommandozeile (als Admin) services.msc ausführen, dann nach MySQL schauen.)
Warum der inaktiv war, bzw. keinen Autostart-Eintrag mehr hatte, ist mir schleierhaft.
Auf jeden Fall in den Windows-Diensten gestartet und läuft.

Danke für die Unterstüzung.

Gruß

Matthias

Vielleicht hilft es ja dem einen oder anderen



   
AntwortZitat
Teilen: