Fakturama druckt ke...
 
Benachrichtigungen
Alles entfernen

Fakturama druckt keine Rechnungen wenn Arbeitsverzeichnis auf Fritz!Nas liegt

3 Beiträge
3 Benutzer
0 Reactions
1,105 Aufrufe
(@Hans Ulrich Kötter)
New Member
Beigetreten: vor 9 Jahren
Beiträge: 1
Topic starter   [#586]

Hallo an Alle,

ich habe Fakturama 1.6.9 und LibreOffice 5.3.2.2 auf 3 Rechnern (Win10, 64bit) installiert, damit wir in der Praxis Rechnugen schreiben können. Das Arbeitsverzeichnis hatte ich zuerst lokal auf meinem PC: alles funktioniert.

Um alle auf das gleiche Verzeichnis zuzugreifen, habe ich an der Fritz!Box im Fritz!NAS das Arbeitserzeichnis angelegt.

Problem:
Fakturama greift auf alle Daten zu und speichert auch korrekt ab. Möchte ich aber ein Dokument drucken, öffnet LibreOffice nicht. Folgende Fehlermeldung kommt:

E:Error starting OpenOffice from file://192.168.178.1/fritz.nas/Lexar/Fakturama/Vorlagen/Rechnung/RechnungPrax.ott : Unsupported URL : "type detection failed" in: com.sebulli.fakturama.office.OfficeDocument/(162)

Was habe ich getestet?
Ich habe das Arbeitsverzeichnis wieder auf meinen lokalen Rechner kopiert und entsprechend bei Fakturama hinterlegt. Nun funktioniert es, LO wird geöffnet - Dokument gedruckt und gespeichert als *-odt und *.pdf, aber wir können nicht mehr an verschiedenen Arbeitsplätzen auf die selben Daten zugreifen bzw. speichern.

Da das Fahlerprotokoll sagt "type detection failed", habe ich in der Systemsteuerung noch einmal für die extension *.ODT LibreOfficeWriter als Standardapp festgelegt. (obwohl es in der lokalen Umgebung auch bisher reibungslos lief).

Wenn ich LibreOffice starte, kann ich von dort aus problemlos auf die gespeicherten Daten im NAS zurückgreifen, öffnen und speichern.

Für Ideen zur Lösung wäre ich sehr dankbar. Beste Grüße, Uli

Anbei mein Fehlerprotokoll

!ENTRY com.sebulli.fakturama 4 0 2017-06-22 09:58:44.125
!MESSAGE Error starting OpenOffice from file://192.168.178.1/fritz.nas/Lexar/Fakturama/Vorlagen/Rechnung/RechnungPrax.ott
!STACK 0
ag.ion.bion.officelayer.document.DocumentException: Unsupported URL : "type detection failed"
at ag.ion.bion.officelayer.internal.document.DocumentService.loadDocument(DocumentService.java:253)
at com.sebulli.fakturama.office.OfficeDocument.(OfficeDocument.java:162)
at com.sebulli.fakturama.office.OfficeManager$1.run(OfficeManager.java:60)
at java.lang.Thread.run(Unknown Source)
Caused by: com.sun.star.lang.IllegalArgumentException: Unsupported URL : "type detection failed"
at com.sun.star.lib.uno.environments.remote.Job.remoteUnoRequestRaisedException(Job.java:160)
at com.sun.star.lib.uno.environments.remote.Job.execute(Job.java:126)
at com.sun.star.lib.uno.environments.remote.JobQueue.enter(JobQueue.java:326)
at com.sun.star.lib.uno.environments.remote.JobQueue.enter(JobQueue.java:295)
at com.sun.star.lib.uno.environments.remote.JavaThreadPool.enter(JavaThreadPool.java:80)
at com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge.sendRequest(java_remote_bridge.java:627)
at com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.request(ProxyFactory.java:141)
at com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.invoke(ProxyFactory.java:123)
at com.sun.proxy.$Proxy3.loadComponentFromURL(Unknown Source)
at ag.ion.bion.officelayer.internal.document.DocumentLoader.loadDocument(DocumentLoader.java:226)
at ag.ion.bion.officelayer.internal.document.DocumentLoader.loadDocument(DocumentLoader.java:116)
at ag.ion.bion.officelayer.internal.document.DocumentLoader.loadDocument(DocumentLoader.java:92)
at ag.ion.bion.officelayer.internal.document.DocumentService.loadDocument(DocumentService.java:246)
... 3 more

!ENTRY org.eclipse.osgi 2 1 2017-06-22 10:20:13.857
!MESSAGE NLS unused message: Wollen in: org.eclipse.equinox.internal.p2.ui.messages



   
Zitat
(@3xhossa)
Mitglied
Beigetreten: vor 12 Jahren
Beiträge: 250
 

Ich vermute, es liegt an der Adressierung des Verzeichnisses über die IP. Versuche doch mal, das Verzeichnis der Fritzbox auf dem PC als Laufwerk einzubinden und dann dieses Laufwerk anzusprechen. Im Explorer sollte es einen Menüeintrag geben, um Netzwerkfreigaben als Laufwerk einzubinden, zumindest gibt es die Option bis Win 7. Dieser Umweg hat schon bei diversen Problemen mit Dateien auf Netzlaufwerken geholfen.


Gruß
3xhossa


   
AntwortZitat
Marc
 Marc
(@eek6smxf)
Reputable Member
Beigetreten: vor 14 Jahren
Beiträge: 229
 

Hallo Uli,

schade, dass es bisher keine Rückmeldung hierzu gab.

Aber ja, das sollte die Lösung sein. Hatte vor kurzem eine Test-VM laufen mit der ich das wie oben
beschrieben realisiert habe, also auch FritzBoxNAS, jedoch war es eine LinuxVM, aber auch hier
musste ich das (Netzwerk-)Laufwerk zunächst mounten/einbinden.

Wenn etwas mit einer Anwendung X (hier Fakturama) nicht zu klappen scheint, dann muss man zunächst
schauen, ob es "ursprünglich", also mit dem Gegebenen überhaupt klappt, sprich Betriebssystem-
eigene Tools. In dem Fall hier wäre man dann schon einen Schritt weiter, denn mit "file://..." sollte man
eigentlich via Browser/Dateimanager (systemeigene Tools) keine Verbindung zu dem Dokument
"ansprechen" bzw. öffnen können.

Grund: die FritzBox selbst! Wenigstens liefert diese auch gleich die Erklärung des möglichen ...

[quote=FritzBox / Heimetz / Speicher (NAS)]
... Auf diese Daten können Sie über FRITZ!NAS, FTP oder über ein Netzlaufwerk zugreifen.

Mit was du arbeiten musst, siehst du hier, siehe z.B. Hilfe FRITZ!Box 7390 > Heimnetz / Speicher (NAS) / Netzlaufwerk
(um es kurz zu machen: mit \fritz.nas bzw. mach es wie vorgeschlagen mit Einbinden eines Netzwerklaufwerks
und dann halt mit LW:...

Wäre schön, wenn du dich nochmal melden würdest, ob und wie du es hinbekommen hast. 🙂



Viele Grüße!

:eek: 😮


   
AntwortZitat
Teilen: