Dokumente werden ni...
 
Benachrichtigungen
Alles entfernen

Dokumente werden nicht mehr gespeichert

19 Beiträge
1 Benutzer
0 Reactions
1,670 Aufrufe
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter   [#262]

Hallo,

seit der Aktualisierung auf die Version 1.6.2 (auf MAC) kann ich zwar ABs, Rechnungen, Lieferscheine o.ä. erstellen und auch als pdf oder odt drucken und zunächst auch speichern.
Nach dem Schließen von Fakturama und dem erneuten Öffnen des Programms sind diese Dokumente jedoch nicht mehr in der Dokumentenliste enthalten.

Die fortlaufende Nummerierung neuer Dokumente stimmt jedoch (Nummernkreis wird aktualisiert) und auch das Drucken funktioniert wie gesagt problemlos.

Woran kann das liegen?

Danke für eine rasche Hilfe.

bzt2012



   
Zitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Hallo,

jetzt kommt beim Versuch ein neues Dokument zu speichern auch noch eine Fehlermeldung:

E:Error inserting a new table column. : data exception: string data, right truncation in statement [ALTER TABLE Documents ADD consultant VARCHAR(256)] in: com.sebulli.fakturama.data.DataBase/checkTableAndInsertNewColumns(526)
E:Error saving dataset AB000165 : user lacks privilege or object not found: CONSULTANT in: com.sebulli.fakturama.data.DataBase/insertUniDataSet(315)

Wo liegt hier das Problem?

Danke,
bzt 2012



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Diese Fehlermeldung sollte kommen, wenn Du versuchst in das Feld (in diesem Fall "Consultant") mehr Zeichen einzugeben wie erlaubt.

Gruß,
Sven



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Hallo,

danke für die Antwort, aber daran liegt es leider nicht. Der Fehler bzw. das Nichtspeichern in der Datenbank passiert auch, wenn man im Feld Consultant nichts oder nur ein Zeichen einträgt.
Wenn man sich das Database.script anschaut sieht es eher so aus, als ob die mit der Version 1.6.2 eingeführte Spalte Consultant in der Datenbank nicht vorhanden ist oder nicht mit einem Standardwert belegt ist, auf jeden Fall weiß die Datenbank offensichtlich überhaupt nicht, wie sie mit dieser neuen Spalte umgehen soll.

Denn wie gesagt, temporär legt Fakturama neue Dokumente an, aber beim Neustart, also wenn die Daten aus der Datenbank geladen werden müssen, sind diese nicht mehr da, also gehe ich davon aus, dass es beim Schreiben in die Datenbank ein Problem gibt.

Zur Info: die Version 1.6.2 habe ich aus dem Programm heraus als neu verfügbares Update installiert. Das sollte ja keine Rolle spielen, ob man die Version komplett neu installiert oder ein verfügbares Update ausführt!?

Hat dieses Problem sonst niemand, der mit 1.6.2 + OpenOffice 3 + Mac arbeitet?

Für weitere Lösungsvorschläge wäre ich sehr dankbar,
bzt2012



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Dieses Problem gibt's in der Tat bei einer Neuinstallation nicht....



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Poste mal Deine error.log datei...



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Hallo,

bei mir liegt fast das gleiche Problem vor. Fakturama 1.6.2 läuft bei mir auf Win7, wurde bereits deinstalliert und komplett neuinstalliert.

Ich kann problemlos eine Rechnung erstellen, gehe dann auf Speichern und sofort erscheint dann die Fehlermeldung:

E:Error saving dataset RE1300001 : data exception: string data, right truncation in: com.sebulli.fakturama.data.DataBase/insertUniDataSet(317)

Wenn ich die Rechnung dann drucke, wird diese im Arbeitsverzeichnis als odt bzw. pdf abgespeichert. Sobald ich jedoch Fakturama beendet habe verschwindet der Eintrag in den Dokumenten.

Wie kann dieses Problem behoben werden?

Bitte um rasche Hilfe.

Danke

Rainer



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Da gibts eine error.log Datei. Kannst Du die hier mal posten?



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Hallo,

bei uns hat die Neuinstallation alleine das Problem auch nicht behoben.

Mit Hilfe eines Bekannten haben wir in der Database.script-Datei selbst den warum auch immer nicht vorhandenen Platzhalter für das Feld "Consultant" in der Tabelle "documents" zusätzlich eingefügt.

Seitdem läuft es wieder problemlos.
Werde morgen mal die entsprechende Stelle aus dem Database.script hier reinstellen.

Gruß,
bzt2012



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Bitte Schau doch mal hier {Fakturama-WorkDir}LogError.log nach und poste diese Datei, die hilft mehr als alles andere!

Gruß,
Sven



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Dann wär noch interessant zu wissen, von welcher Version ihr upgegraded habt.



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Die Datenbank wird beim Start der Anwendung geprüft, ob da alles da ist (an Feldern). Wenn nicht, wird das einfach dazugemacht. Möglicherweise hat das irgendwo gehakt. Obwohl das ein Mechanismus ist, der schon die ganze Zeit ganz passabel läuft...

Viele Grüße,
Ralf.



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Naja, ohne log Datei können wir eh nicht helfen...

Viele Grüße,
Sven



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Hallo,

bei mir hat sich das Problem gelöst. Mein Ergänzungstext unter Punkt Zahlungsarten war auf der Seite "bezahlt Text" sowie "unbezahlt Text" jeweils zu lange. Hier dürfte wahrscheinlich eine maximale Zeichenanzahl einprogrammiert sein. Nach starker Kürzung des Textes kamen keine Fehlermeldungen mehr.

Es wäre trotzdem zu empfehlen hier die Zeichenanzahl entweder anzuzeigen und herunterzählen zu lassen bzw. stark zu erhöhen und auch anzuzeigen.

Vielleicht hilft meine Entdeckung auch bei allen anderen derartigen Problemen.

Schöne Größe

Rainer



   
AntwortZitat
(@rhe_dummy)
Noble Member
Beigetreten: vor 57 Jahren
Beiträge: 729
Topic starter  

Ich werde das mal weiterverfolgen. Danke für den Tip.

Viele Grüße,
Ralf.



   
AntwortZitat
Seite 1 / 2
Teilen: